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Technical Support

Free technical support for registered users of A-Talk for Windows is available from a variety of
services.

Electronic Services

Using CompuServe
As a CompuServe user, you can now obtain free technical support around the clock. You can 
ask questions, share ideas and get important information about Felsina Software products 
via CompuServe. By accessing the Felsina Software section (GO ATALK) of the Windows 
Networking Applications Forum, you'll gain valuable information on all of our current 
products, as well as late-breaking news and soon-to-be and newly released products. GO 
ATALK also connects you directly to our technical support team and provides easy access to 
the most current file updates. Felsina Software's e-mail address on CompuServe is 
74777,1006. If you are not currently a CompuServe member, please look for a valuable offer
included with this package for one free month of unlimited access to over 80 services, and a 
$15 usage credit good toward exploring optional extended services.

Using the Internet Network

E-mail
You can e-mail your questions to Felsina Software using the Internet, a collection of 
computer networks and gateways. Internet is available 24 hours a day, seven days a week, 
including holidays. You can e-mail your questions to felsina@crl.com. Include your 



registration number with you message.

FTP
You can download the latest version of A-Talk's Test Drives, by using anonymous FTP to 
ftp.crl.com. Change the directory to users/fe/felsina.

World-Wide-Web
If you have access to a Web browser such as Mosaic, Enhanced Mosaic or Netscape, you can 
access Felsina Software's home page on the Web: http://www.crl.com/~felsina/. Our Web 
service includes information on current products, Test Drives for download, press releases, 
as well as late-breaking news on soon-to-be and newly released products.

Telephone Support

Using the Felsina Fax Line
Fax your questions to (213)-669-1893. Include a fax number where Tech Support can return 
a reply.

Mail Support

Mail your questions to:

Felsina Software, Inc.
Attn: Technical Support
4440 Finley Ave., Ste. 108
Los Angeles, CA 90027-2760



Office Compatible

A-Talk for Windows is a certified Microsoft Office Compatible product. As stated by Microsoft:

"Products with the Microsoft Office Compatible Logo offer a distinct advantage - they share the Microsoft 
Office family's familiar look and consistent way of doing things. The similarities start with toolbars, menus, 
and commands and can include much more, such as the same easy way of sharing text, numbers, and 
graphics." 

A-Talk includes all of the following Microsoft Office Compatible features:

1. Main Screen and Dialog Box Appearance
2. Basic Toolbar
3. Tooltips
4. Basic and Advanced Menus
5. Accelerator Keys
6. File Open, File Save As and File Print Dialog Boxes
7. Startup Screen and About Box
8. Help Contents, Search, Index, Tutorial, Tech Support, Office Compatible
9. Shortcut menus
10. Status Bar
11. Main Window Title Bar
12. Integration with Cut, Copy and Paste, Drag/Drop
13. Integration with Microsoft Mail

All Microsoft Office Compatible features are activated by default, except for the Accelerator 
Keys. When A-Talk is initially set up:
1. the accelerator keys for the File and Edit menus use the CTRL+SHIFT+key combination 
instead of the standard Office accelerator CTRL-key combination;
2. the accelerator key combination for the Help Contents menu is Alt-F1 instead of the 
standard Office accelerator key F1;



3. Context-sensitive help is not available.
The reason behind the default behavior is that the standard Office accelerator key 
combinations have traditional meaning with the mainframe and UNIX connectivity 
environment.
To activate the standard Office accelerator keys you must invoke the Option Preferences 
dialog box, and select the checkbox named Use Function and Ctrl keys for Windows.



Programming with A-Talk

Script Commands
Script Language
Writing your own Script



Reference Information

General Reference

Definitions
Keyboard Guide
Menu Commands
Installing and Starting A-Talk
Script Language Reference



Examples and Demos

Excel Demo
Tektronix Demos



Using A-Talk

Essential Skills
Settings Control
File Transfers
Selected Text Control
Printing
Phonebook/Communications with Hosts
Tektronix
Miscellaneous
Mail and Network DDE



Excel Demo

Single Workstation Demo

You can optionally copy, during installation of A-Talk, three script files and two Excel files that
demonstrate DDE (and possibly Network DDE if used in a Windows for Workgroups 
environment) between A-Talk and Microsoft Excel 5.0. The following files are copied to your 
hard disk:

DJNS.ATK 120 11-05-92 8:14p
STOCKS.ATK 77 02-05-93 10:24a
DJNSREMT.ATK 491 10-06-93 1:23a
DJNS.XLC 6,144 05-11-94 11:05p
DJNS.XLS 19,968 05-11-94 11:01p

The DJNS.ATK script may be used to log into the Dow Jones News Service (DJNS). The 
STOCKS.ATK script may be used with the DJNS to continually update the terminal screen with
"live on-line stock quotes. The Microsoft Excel 5.0 DJNS sheet and chart establish links with 
A-Talk's terminal window.

Network DDE Demo

The above mentioned files plus the DJNSREMT.ATK script file may be used to establish 
Network DDE hot links between A-Talk programs running on networked machines (either 
Windows for Workgroups or Windows NT). The DJNSREMT.ATK initial lines are as follows:

INITIATE ch0 "\\FELSINA\NDDE$" "ALLAT$
# first MSOFT
ADVISE ch0 "R5C31:R5C36" "R5C31"
ADVISE ch0 "R5C41:R5C46" "R5C41"
ADVISE ch0 "R5C51:R5C56" "R5C51"
ADVISE ch0 "R5C61:R5C66" "R5C61"
....

The file must be edited by substituting the name FELSINA with the computer name of the 
workstation attached to the modem connected to DJNS. The same computer must also be 
previously set up with a share names ALLAT$, with complete access to the A-Talk terminal 
screen.



Tektronix Demos

You can optionally copy, during installation of A-Talk, a number of Tektronix 4014 
demonstration plots. The following files are copied to your hard disk:

SHUTTLE.TEK 6,545 12-20-89 8:59p
ICEM.TEK 24,518 01-06-90 1:03a

You can "replay" the demos, as follows:

1. Select Options Terminal Tektronix
2. Select File Replay.
3. Enter one of the file names mentioned above.



Essential Skills

Connecting to a Remote Computer
Copying Text to the Clipboard
Dialing a BBS
Dialing a Phone Number
Dragging and Dropping Files
Exiting
Installing A-Talk
Printing Incoming Text
Receiving Binary Files
Sending Binary Files
Sending Selected Text to a Host
Setting Parameters for Communication
Setting Terminal Emulation
Using the Phonebook for Dialing



Settings Control

Changing the Colors of the Window
Loading Settings from ATALK.INI
Loading Settings from Existing .INI Files
Saving Control Codes in Incoming Text Files
Saving Settings to ATALK.INI
Saving Settings to Files
Selecting Flow Control for Text File Transfers
Setting Line and Character Delays
Setting Parameters for Communication
Setting Terminal Emulation
Setting Tektronix Emulation
Specifying Modem Commands



File Transfers

Dragging and Dropping Files
Receiving Binary Files
Receiving Mail as Text
Receiving Text Files
Sending Binary Files
Sending Mail as Text
Sending Text Files
Viewing Captured Text Files



Selected Text Control

Copying Text to the Clipboard
Selecting Everything in the Terminal Window
Selecting Text on Your Window
Sending Selected Text to a Host



Printing

Getting a Cheap Printout
Printing Incoming Text



Phonebook/Communications with Hosts

Adding a Host to the phonebook
Connecting to a Remote Computer
Creating a Login Script with Script Tutor
Creating a New Phone Book
Dialing a BBS
Dialing a Phone Number
Disconnecting from a Remote Computer
Loading an Alternate Phonebook
Using the Phonebook for Dialing



Tektronix

Replaying a Tektronix Plot
Saving a Tektronix Bitmap
Saving a Tektronix Picture
Saving in Tektronix PLOT-10 Format



Miscellaneous

Defining the Function Keys
Exiting
Installing A-Talk
Timing Terminal Sessions



Mail and Network DDE

Adding a Network DDE Share
Deleting a Network DDE Share
Inserting DDE Hot and Warm Links
Linking to a Network DDE Share
Sending a Message with MAPI or Microsoft Mail
Signing In to MAPI or Microsoft Mail
Unlinking from a Network DDE Share



A-Talk Help Index

The Index lists Help topics available for A-Talk. Use the 
scroll bar to see entries not currently visible in the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu.

Commands
Edit Menu
File Menu
Format Menu
Help Menu
Options Menu
Phone Menu
Tektronix Edit Menu
Tektronix File Menu
Tektronix Options Menu
Tools Menu
Transfer Menu
View Menu

Glossary
Defined Terms

Procedures
Adding a Host to the Phone Book
Adding a Network DDE Share
Changing the Colors of the Window
Connecting to a Remote Computer
Copying a Tektronix Bitmap to the Clipboard
Copying a Tektronix Metafile to the Clipboard
Copying Text to the Clipboard
Creating a Login Script with Auto Script
Creating a New Phone Book
Defining the Function Keys
Deleting a Host from the Phone Book
Deleting a Network DDE Share
Dialing a BBS
Dialing a Phone Number
Disconnecting from a Remote Computer
Dragging and Dropping
Exiting A-Talk
Getting a Cheap Printout
Inserting DDE Hot and Warm Links
Installing A-Talk
Linking to a Network DDE Share
Loading an Alternate Phone Book
Loading Settings from ATALK.INI
Loading Settings from Existing Initialization Files
Printing Incoming Text
Receiving Binary Files with Protocols
Receiving Mail as Text
Receiving Text Files with Protocols
Replaying a Tektronix Plot



Saving a Phone Book
Saving a Tektronix Bitmap
Saving a Tektronix Picture
Saving Control Codes in Incoming Text Files
Saving in Tektronix PLOT-10 Format
Saving Settings to ATALK.INI
Saving Settings to Files
Selecting Everything in the Terminal Window
Selecting Flow Control for Text File Transfers
Selecting Text on Your Window
Sending a Message with MAPI or Microsoft Mail
Sending Binary Files with Protocols
Sending Mail as Text
Sending Selected Text to a Host
Sending Text Files with Protocols
Setting Line and Character Delays
Setting Parameters for Communication
Setting Terminal Emulation
Setting Up Tektronix Emulation
Signing In to MAPI or Microsoft Mail
Specifying Modem Commands
Timing Terminal Sessions
Unlinking from a Network DDE Share
Using the Phone Book for Dialing
Viewing Received Text Files
Writing Your Own Script

Dialogs
Edit Add Share Dialog
Edit Link to Share Dialog
Edit Remove Share Dialog
Edit Unlink from Share Dialog
File Append To Dialog
File Open Dialog
File Save As Dialog
File Save Selection As Dialog
File Print Dialog
File Print Setup Dialog
Format Colors Dialog
Format Font Dialog
Format VT SET-UP Display Dialog
Format VT SET-UP Keyboard Dialog
Kermit Packet Settings Dialog
Kermit Protocol Settings Dialog
Options Communications Dialog
Options Custom Modem Dialog
Options Function Keys Dialog
Options Modem Dialog
Options Preferences Dialog
Options Protocol Transfer Dialog
Options Terminal Dialog
Options Text Transfer Dialog
Phone Book Dialog
Phone Book Load Dialog
Phone Book Save Dialog



Phone Dial Dialog
Tektronix File Print Dialog
Tektronix File Replay Dialog
Tektronix File Save Bitmap Dialog
Tektronix File Save Picture Dialog
Tektronix File Save Plot Dialog
Tektronix Options Controls Dialog
Tools Script Dialog
Tools Script Tutor Dialog
Transfer Receive Protocol Dialog
Transfer Receive Text Dialog
Transfer Send Protocol Dialog
Transfer Send Text Dialog
Transfer Set Directory Dialog
ZMODEM Receive Settings Dialog
ZMODEM Send Settings Dialog

A-Talk Scripts Topics
Script Commands
Script Language

Sample Fonts
A-Talk fonts

Keyboard Topics
Windows Keys



The Index contains a list of all Help topics available for the Help Example. For information on how to use 
Help, press F1 or choose Using Help from the Help menu.



Edit Menu

The Edit menu includes commands that enable you to delete text, transfer text to and from the Clipboard, 
send mail, and work with Network DDE shares.

For more information, select the Edit menu command name.

Add Share Allows an A-Talk server to share information.
Clear Deletes the contents of the scroll buffer.
Copy Copies selected text to the Clipboard.
Cut Copies selected text to the Clipboard and deletes it.
Link to Share Starts Network DDE hot links.
Paste Sends text in the Clipboard to the host.
Remove Share Removes Network DDE shares.
Select All Selects everything in the terminal window.
Send To Host Sends selected text to the host.
Send Sends messages via the Mail system.
Unlink from Share Cancels Network DDE hot links.



File Menu

The File menu includes commands that enable you to open, add to, save and print selected text and files.

For more information, select the File menu command name.

Append Selection To Appends selected text to an existing file.
Exit Exits A-Talk.
New Resets the default configuration to the values in the ATALK.INI file.
Open Installs a previously saved set of communications parameters.
Print Prints the contents of the terminal window.
Print Setup Use to set up various printer options.
Save Saves communications parameters in the ATALK.INI file.
Save As Saves communications parameters in a file you designate.
Save Selection As Saves selected text to a new file.
Send Sends downloaded files via the Mail system.



Options Menu

The Options menu includes commands that enable you to set various parameters necessary for 
communication, terminal emulation, and function keys.

For more information, select the Options menu command name.

Communications Sets parameters for communication.
Function Keys Enables you to define 44 function keys.
Modem Sets modem and telephone variables.
Preferences Sets beep, journal and scroll buffer.
Protocol Transfer Sets protocols and other transfer options.
Save Workspace on Exit Saves the position of the A-Talk window.
Smooth Scroll Allows scroll only upon release of the mouse.
Terminal Sets terminal variables (emulator, bell).
Text Transfer Sets the "end of line" characters and delays.



Format Menu

The Format menu includes commands that enable you to set various parameters necessary for formatting
text, the colors, the keyboard and display.

For more information, select the Format menu command name.

Colors Changes the colors of the ANSI text.
Font Selects the terminal font.
VT SET-UP Display Displays the data on your screen in selected ways.
VT SET-UP Keyboard Sets keyboard options.



Phone Menu

The Phone menu includes commands that enable you to dial, write and use login scripts, and write your 
own phone book.

For more information, select the Phone menu command name.

Auto Answer Puts your modem into auto-answer mode.
Dial Dials without going into the Phone Book.
Hang Up Disconnects your modem.
Phone Book Enables easy access to often used hosts.
Send Break Interrupts connection with the host.



Tools Menu

The Tools menu includes commands that enable you to write and use login scripts, and use speech.

For more information, select the Tools menu command name.

Auto Script Creates a login script as you log in.
BBS Turns your PC into a mini BBS.
Script Activates a login script without using the Phone Book.
Script Editor Activates an interactive script editor.



Transfer Menu

The Transfer menu includes commands that enable you to send and receive files.

For more information, select the Transfer menu command name.

Command Receives files in Kermit Server (Kermit Get) and executes ZMODEM commands.
Kermit Finish Shuts down Kermit Server mode.
Receive Protocol Receives files except with Kermit Server mode and Compuserve B+.
Receive Text Receives everything that comes through the serial port.
Send Protocol Sends files.
Send Text Sends previously edited mail and other text files.
Set Directory Selects disk/directory with ZMODEM, YMODEM Batch, Kermit Get and 

CompuServe B+.



Tektronix File Menu

The Tektronix File menu includes commands that enable you to save, replay and print images.

For more information, select the Tektronix File menu command name.

Print Gives you a hardcopy of your Tektronix screen.
Print Setup Used to set up various printer options.
Replay Replays files captured in PLOT-10 format.
Save Bitmap Saves a bitmap to a file.
Save Picture Saves a picture in Metafile format.
Save Plot Saves a picture in PLOT-10 format.



Tektronix Edit Menu

The Tektronix Edit menu includes commands that enable you to copy images to the Clipboard.

For more information, select the Tektronix Edit menu command name.

Copy Saves a bitmap to the Clipboard.
Copy Picture Saves a picture to the Clipboard in Metafile format.



Tektronix Options Menu

The Tektronix Options menu includes commands that enable you to set controls and the emulation mode.

For more information, select the Tektronix Options menu command name.

Controls Sets Tektronix emulation options.
Mode Enables switching to the VT100 terminal.



Transfer Receive Text Menu

These commands enable you to receive everything that comes through the serial port. This is for systems
that do not support the error-checking protocols Kermit, XMODEM, 1K-XMODEM, YMODEM Batch or 
ZMODEM.    Data transmission with this menu is risky.    Make sure that:

1)    Your host or remote micro supports the XON/XOFF handshake or you are receiving a small file of less
than 4,000 characters (4 Kbytes).
2)    You are NOT transmitting a binary file.
3)    You do not have a noisy telephone line. 

For more information, select the Transfer Receive Text menu command name.

Pause Temporarily ends the receiving process.
Start Starts the receiving process.
Stop Closes the file.
View Enables you to preview the contents of the file.



Help Menu

The Help menu enables you to obtain assistance in using A-Talk.

For more information, select the Help menu command name.

About A-Talk program information, version number and copyright notice.
Commands Lists menus and their actions.
Contents Main A-Talk help topic.
Examples and Demos Lists the examples for learning A-Talk. keywords.
How to Use Help How to use buttons, commands, and procedures.
Index A list of all Help topics.
Keyboard Help for use of the keyboard.
Office Compatible Explains Microsoft Office Compatible features.
Procedures Explains how to achieve your objectives with A-Talk.
Search for Help on Searches for help topics containing keywords.
Technical Support  A list of technical support options.



View Menu

The View menu enables you to set the timer.

For more information, select the View menu command name.

Split Window Enables CB or chat mode.
Status Bar Shows or hides the status bar.
Timer Starts or stops a timer in the status bar.
Toolbar Shows or hides the toolbar.



Edit Clear Command

Deletes the contents of the scroll buffer.



Edit Copy Command

Preselected text in your terminal window is copied to the Clipboard or used for DDE hot links.

See Also
How To Insert DDE Hot Links



Edit Select All Command

This is a shortcut for selecting everything in the terminal window.



Edit Paste Command

Sends what is in the Clipboard to your host.



Edit Send To Host Command

Bypassing the Clipboard, you may send selected text to the host.



File Exit Command

Exits A-Talk. If parameters have changed since startup, a dialog will ask whether you want to save the 
new parameters or not.



File New Command

Resets the default configuration to the values stored in the ATALK.INI file.



File Open Command

Installs the configuration parameters from a previously saved configuration file.    Select the file from the 
list box.    The command has a dialog box.



File Print Command

Prints the contents of the terminal window if the Capture to Printer checkbox is not selected, and prints 
everything that comes in through the serial port if the Capture to Printer checkbox is selected.

If you are capturing a session, your session will slow to the speed of the printer.    Uncheck Capture to 
Printer when you no longer want a printout.    Your printout will be formatted according to the printer type 
and options selected in the Window's Control Panel or the File Print Setup dialog box.

The command has a dialog box.

See Also
Getting a Cheap Printout
Printing Incoming Text



File Print Setup Command

Sets various printer options before printing.    The command has a dialog box.



File Save Command

Saves the default configuration necessary for communication in the ATALK.INI file.



File Save As Command

Saves a configuration necessary for communication under the file name you designate. You should use 
the extension .ATI.

The command has a dialog box.



File Send Command

Sends the last downloaded file and any selected text to other computers on the LAN via Microsoft Mail, 
Lotus cc:Mail, Lotus Notes Mail or other compatible MAPI or VIM system.



Format Colors Command

Enables you to change the colors of the ANSI text by using the Red, Green and Blue controls. This 
command has a dialog box.



Options Function Keys Command

Enables you to define forty-four function keys.

This command has a dialog box.

See Also
A-Talk Keys



View Timer Command

This selection works as a toggle, either starting or stopping a timer in the status bar.    

It displays the date, the time, the amount of memory and the value of the timer (starting at zero when it is 
turned on).



View Status Bar Command

This selection works as a toggle, either showing or hiding the status bar, which may include the timer and 
any current keyboard-typing modes.



View Tool Bar Command

This selection works as a toggle, either showing or hiding the toolbar, which allows you to select 
frequently used menu items.



View Split Window Command

This selection works as a toggle, either providing or removing a separate window for whatever you type. It
is useful for electronic conferences or talking to sysops.    



Options Communications Command

Sets various parameters necessary for communication.    This command has a dialog box.



Tools Speech Command

Sets various parameters and filters for speech.    This command has a dialog box.



Phone Auto Answer Command

For Hayes-compatible modems, this command allows your modem to answer calls even when you are 
not present.    This command should be used before setting up A-Talk to be used as a remote host, such 
as a BBS.



Phone Dial Command

Dials without going into the Phone Book.    The telephone number will not be saved.    If the line is busy or
dialing cannot be completed, you will get an error message.

This command has a dialog box.

For a permanent telephone directory, select: Phone Book.



Phone Hang Up Command

Use Hang Up to disconnect your modem according to your modem type. If using the Custom Modem 
option, it will Drop DTR, if selected, or it will use the Hang Up Command Code.



Options Modem Command

Sets modem and telephone variables, such as redialing, hanging up and line options.

This command has a dialog box.



Phone Phone Book Command

Enables easy access to frequently used hosts.

This command has a dialog box.



Tools Script Command

Activates a login script without going into the Phone Book.    Before using this option, write a login script.

To end the execution of your script file before it is finished, select End Script which will appear in place of
Script.

This command has a    dialog box.

See Also
Creating a Login Script with Script Tutor
Script Commands
Script Language
Using the Script Editor



Phone Send Break Command

This command simulates the break key, which is used to interrupt connection between the terminal and 
the host.    It may have to be repeated to be effective.



Tools BBS Command

This command turns your PC into a small Bulletin Board System. It is useful when you want to access 
your PC from a remote location or set up your own bulletin board. Since this command invokes an 
editable script (minibbs.atk), you may modify the BBS to suit your own needs.



Transfer Command Command

This menu appears as Kermit Get when the selected protocol is Kermit and it is used when receiving files
from a Kermit Server.    When receiving for other protocols, including Kermit (non-server mode), use 
Receive Protocol.

This menu appears as Command when the selected protocol is ZMODEM, and it is used to send and 
execute host commands remotely from your PC.

This menu is grayed when any other protocol is selected.

The command has a dialog box.



Transfer Kermit Finish Command

This command is used only to shut down the Kermit Server mode. This command is grayed when any 
other protocol besides Kermit is selected.



Transfer Set Directory Command

Selects drive/directory with ZMODEM, YMODEM Batch, Kermit Get and CompuServe B+.

There are only a few cases in which, during the receiving process, no file dialog box comes up: receiving 
with ZMODEM, YMODEM Batch and Kermit Get and Compuserve B+.    Since the dialog box allows you 
to select the directory and/or drive on which the received file is stored, these cases require Set Directory,
for changing the drive/directory on which the received file is stored.    

The command has a dialog box.



Options Protocol Transfer Command

Sets protocols and other transfer options.

The command has a dialog box.



Transfer Receive Protocol Command

Receives files by using communications protocols except with Kermit Server mode and CompuServe B+.

The command has a dialog box when used with protocols that do not include the file name as part of the 
transfer.



Transfer Send Protocol Command

Sends files using a file transfer protocol.

The command has a dialog box.



VT SET-UP Display Command

For VT100 and similar terminals, displays the data on your screen in selected ways.

The command has a dialog box.



Format Font Command

Selects your terminal font.

The command has a dialog box.



VT SET-UP Keyboard Command

For VT100 and similar terminals, sets keyboard options.

The command has a dialog box.



Options Terminal Command

Enables emulation of various terminals and sets bell.

The command has a dialog box.



Options Text Transfer Command

Refers to how computers store the end of line characters in their files and how long you want the line and 
character delays to be.

This command has a dialog box.



Transfer Send Text Command

Sends an text file.    This can be used to send mail and will save connect time. This is for systems that do 
not support the error-checking protocols Kermit, XMODEM, 1K-XMODEM, YMODEM Batch or ZMODEM. 
Data transmission with this menu is risky.    Make sure that:

1)    Your host or remote micro supports the XON/XOFF handshake or you are receiving a small file of less
than 4,000 characters (4 Kbytes).
2)    You are NOT transmitting a binary file.
3)    You do not have a noisy telephone line. 

If you select End Send, the transmission will be interrupted. If you want to complete the transmission, 
wait for the File Sent message.

This command has a dialog box.



Tektronix Options Controls Command

Sets hardware emulation options that would be available on a real Tektronix terminal.

The command has a dialog box.



Tektronix Edit Copy Command

Copies an image from the Tektronix window to the Clipboard in bitmap format.



Tektronix Edit Copy Picture Command

Copies an image from the Tektronix window to the Clipboard in Metafile format.



Tektronix Options Mode Command

Enables switching between the VT100 terminal window and the Tektronix window. 



Tektronix File Print Command

Gives you a hardcopy of your Tektronix Graphics window. Before printing, make your printer selections in 
the Tektronix File Print Setup and the Windows Printer Control Panel. Your printer output depends on 
those selections.

The command has a dialog box.



Tektronix File Replay Command

A-Talk enables you to capture in PLOT-10 format using the Tektronix File Save Plot command. Use 
Replay to "replay" the plot on the PC in order to save it in one of the other formats. This is useful for 
saving connect charges.

The command has a dialog box.



Tektronix File Save Picture Command

Creates a file compatible with Windows Metafile format. Make this selection before drawing your image.

The command has a dialog box.



Tektronix File Save Bitmap Command

Creates a file compatible with the Windows 3.0 Bitmap format.

The command has a dialog box.



Tektronix File Save Plot Command

Saves in PLOT-10 format. Select Tektronix File Save Plot just before starting to display the image that is
being captured (before pressing the carriage return).

The command has a dialog box.



Transfer Receive Text Stop Command

Closes the text file that is being received. The next time the you start receiving with Start, the dialog box 
will pop up asking for a new file name.



Transfer Receive Text Pause Command

Temporarily ends the receiving process.    

After pausing, you may reopen the file at any time. The additional text will be appended to your file.

Pause before using Stop or View.



Transfer Receive Text Start Command

Starts the receiving process. You must Pause the receiving process before using Stop or View.

This command has a dialog box.



Transfer Receive Text View Command

Enables you to preview the contents of the received file. Before previewing, you must Pause. Once the 
receiving process is Paused, you can preview the file by using the View option.

Your session is displayed in a Notepad window.    Scroll through the file using the Notepad scroll bars. 
Notepad has a 64K limit for the size of the file it can display. If the received file exceeds 64K, you will 
have to use another text editor.



Options Preferences Command

Enables you to set the number of pages in the scroll buffer, create a log and get a bep instead of a dialog 
box.

This command has a dialog box.



Options Save Workspace on Exit Command

Enables you to save the position and size of the A-Talk window for the next startup.



Options Smooth Scroll Command

Enables you to scroll smoothly within the terminal window history buffer or arrest the scrolling until the 
release of the mouse button.



Edit Add Share Command

Enables an A-Talk DDE server to share information on the network.

This command has a dialog box.



Edit Link to Share Command

Enables an A-Talk DDE client to obtain information from another computer on the network.

This command has a dialog box.



Edit Unlink from Share Command

Enables an A-Talk DDE client to cancel a hot link established with another computer on the network.

This command has a dialog box.



Edit Remove Share Command

Deletes a Network DDE Share created with the Add Share Command.

This command has a dialog box.



Edit Cut Command

Copies selected text to the Clipboard and deletes it from the window.



Edit Send Command

Sends selected text to other computers on the LAN via Microsoft Mail, Lotus cc:Mail, Lotus Notes Mail or 
other compatible MAPI or VIM system.



File Append Selection To Command

Appends text selected from the terminal window to an existing file.

This command has a dialog box.



File Save Selection As Command

Saves text selected from the terminal window to a new file.

This command has a dialog box.



Tools Script Editor Command

Activates an interactive program that helps you write correct scripts for login and other automatic tasks.



A-Talk Fonts

Any fixed-spaced font can be used in A-Talk. VT100/VT52/H19-compatible fonts are supplied with the A-
Talk package.



Tools Auto Script Command

Creates a login script as you log in to a service.

This command has a dialog box.



Context-Sensitive Help Button

This button shows the arrow-question mark cursor, as when typing SHIFT-F1, if the SCROLL-LOCK key 
is pressed.



Tektronix Button

This button turns the terminal into Tektronix emulation.



Communications Options Dialog Box

Sets various parameters necessary for communication.

Click on individual controls to find out more information. 



Text Transfer Options Dialog Box

Refers to how computers store the "end of line" characters in their files and how long you want the line 
and character delays to be.

Click on individual controls to find out more information. 

 



Protocol Transfer Options Dialog Box

Sets protocols and other transfer options.

Click on individual controls to find out more information.



VT SET-UP Display Dialog Box

Enables selection of ways to display data on your screen.

Click on individual controls to find out more information.



Kermit Packet Settings Dialog Box

Enables selection of Kermit packet parameters. Inbound and outbound packets have a number of 
parameters which can be altered for various circumstances. You may set the following for each type. Note
that you may have to set the corresponding values on the remote Kermit as well for proper 
communication to take place.

The Kermit Packet Settings dialog box includes the following areas:

End of Line character
The character which terminates a packet. The default is carriage return (CTRL-M).

Packet sizeThe maximum length of a packet in bytes from the sequence number byte and including the 
checksum or CRC characters. The default is 80.

Padding character
The character to use for padding. The default is NUL (CTRL-@).

Padding count
The number of padding characters to send before a packet. The default is 0.

Quote character
The character used to signal that the next character is in the range 0-31, 128-159, or is a delete character
(127). The default is #.

Start of packet
The character which is used to mark the start of a Kermit Packet. The default is SOH (CTRL-A). You 
would change this character only if the machine intercepts SOH (Start Of Header).

Timeout
The number of seconds that the remote Kermit should wait before timing out. The default is 5 seconds.



Kermit Protocol Settings Dialog Box

Enables selection of Kermit protocol parameters.

The Kermit Protocol Settings dialog box includes the following areas:

1-Byte Checksum
Selects the standard Kermit 1-byte checksum computation. This has proved to be quite robust in practice.

2-Byte Checksum
Selects the standard Kermit 2-byte checksum computation.

3-Byte CRC
Selects a cyclic redundancy checksum computation. This is most useful when transferring long packets or
when operating on noisy lines.

Discard Partial File
If selected, partial files will be deleted if they have been received during a transfer interrupted by the user 
or an error condition.

Duplicate File Warning
If selected, then an incoming file with the same name as an existing one will be renamed, so as to not 
overwrite the old one. The new name appends or replaces part of the old name with a unique generation 
number.

Retry limit
Sets the number of retries in reading a packet before the protocol gives up. 

Send Delay before first packet
Sets the number of seconds before the first packet is sent. It is mainly used to give the receiver time to 
get ready before the initialization packet arrives.

Timer
If selected, the transfer will be retried after no packets have been received within the given number of 
seconds. After a certain number of unsuccessful retries, Kermit will exit. The elapsed time and the number
of retries can be set.

Warning Bell
If selected, the bell sounds when a transaction is complete or canceled.



ZMODEM Receive Settings Dialog Box

Enables selection of ZMODEM Receive management and conversion options.

The ZMODEM Receive Settings dialog box includes the following areas:

Append to existing local file
Forces an interrupted transfer to resume. A-Talk is able to find this out automatically and will pop up a 
dialog asking whether to overwrite or resume the transfer. This selection turns off the display of the dialog 
and forces the resumption of the transfer.

Escape Control characters
Receiver expects control characters to be sent as printable characters (escape), and will then translate 
them back to control characters. This should be used only if the transmission line is sensitive to control 
characters.

Overwrite existing local file
If there is a local file with the same name and location of the one being received, it is deleted (default).

Protect existing local file
If there is a file with the same name and location of the one being received, it is not overwritten.



ZMODEM Send Settings Dialog Box

Enables selection of ZMODEM Send management, conversion and other options.

The ZMODEM Send Settings dialog box includes the following areas:

Conversion Options
You can select one and only one of the following options for converting files:

Convert EOL to remote convention
Convert the received end of line character (EOL) to the local end of line convention. The supported end of
line conventions are CR/LF (used on MS-DOS and Windows) and NL (UNIX). Either of these two end of 
line conventions meet the permissible ASCII definitions for Carriage return and Line Feed/New Line. 
Other processing appropriate to ASCII text files and the local operating system may also be applied by 
the receiver.

Inhibit conversion
Plain Binary transfer. There is no conversion of any kind.

Resume interrupted transfer
Recover/resumes an interrupted file transfer. If the destination file exists and is no longer than the source,
append to the destination file and start transfer at the point where the transfer was interrupted. This option
does not apply if the source file is shorter. Files that have been converted cannot have their transfer 
recovered.

Management Options
You can select one and only one of the following options for managing files:

Append to destination file
Appends source file contents to the end of the existing destination file (if any).

None
No management instruction for receiver.

Protect destination file
Protects the destination file by transferring the source file only if the destination file is absent.

Replace existing destination file
Overwrites the destination file with the same name as the file being sent.

Send file if file length differ
Compares the source and destination files. Transfer if the file length or the file polynomials differ.

Send file if source file newer
Transfers the source file if the destination file is absent. Otherwise, overwrites the destination file if the 
source file is newer.

Send file if source file newer or longer
Transfers the source file if the destination file is absent. Otherwise, overwrites the destination file if the 
source file is newer or longer.

Send if different length or dates
Transfers the source file if the destination file is absent. Otherwise, overwrites the destination file if the 
source and the destination files have different length or dates.



Skip file if same not present at destination
If selected, instructs the receiver to bypass transferring the current file if the receiver does not have a file 
with the same name.

Other Options
You can select one and only one of the following options for sending files:

Delete file after transmission
Deletes the source file after transmitting it.

Escape control characters
Sender (transmitter) expects control characters to be sent as sequences of printable characters (escape).
This should be used only if the transmission line is sensitive to control characters.

Send full path name
The entire path name, including    : and \ is sent to the receiver.

Use CRC-16 (instead of CRC-32)
Use lower overhead CRC-16, which uses fewer characters and therefore is faster than CRC-32. Useful 
with error-correcting modems and clean lines.



VT SET-UP Keyboard Dialog Box

Sets keyboard options.

Click on individual controls to find out more information.



Font Format Dialog Box

The Font Format dialog box enables you to set the following font options.    Once you have made your 
selection, a sample of the font you have selected will appear in the Sample box.

Font
Enables you to select the font you want in the list box.

Font Style
Enables you to select the font style you want in the list box.

Size
Enables you to select the font size you want in points.    The larger the number, the larger the font.



Terminal Options Dialog Box

Sets terminal variables (emulator, bell and VT200 mode).

Click on individual controls to find out more information.



Tektronix Options Controls Dialog Box

Sets Tektronix hardware emulation options.

Click on individual controls to find out more information.



Tektronix File Replay Dialog Box

Replays files captured in PLOT-10 format.

The Tektronix File Replay dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file is stored.

File Name
Click on the file from which the PLOT-10 data will be retrieved.

List Files of Type
Lists all the extensions of pertinent types of files.



Tektronix File Save Picture Dialog Box

Saves a picture in Metafile format.

The Tektronix File Save Picture dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Tektronix File Save Bitmap Dialog Box

Saves a picture in Windows Bitmap format.

The Tektronix File Save Bitmap dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Tektronix File Save Plot Dialog Box

Captures and saves a Tektronix graphics plot in a PLOT-10 format file you designate.

The Tektronix File Save Plot dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save Files as Type
Lists all the extensions of pertinent types of files.



Function Keys Options Dialog Box

Enables you to define forty-four function keys for all emulators except DEC VT-220, which allows you to 
define thirty-six function keys (all unshifted keys F1 through F12 send predefined escape sequences in 
DEC VT-220 emulation). 

The Function Keys Options dialog box includes the following areas:

Key
Choose the key you want to define.

Modifier
Choose how you want the defined key to be modified.

String
Use normal ASCII characters (letters, numbers and punctuation) and special, or control characters.



Colors Format Dialog Box

Enables you to change the colors of the ANSI text. Select the color you want to change by clicking on one
of the boxes at the bottom of the dialog box.

The Colors Format dialog box includes the following areas:

Blue
Adjusts the amount of blue in the color selected.

Green
Adjusts the amount of green in the color selected.

Red
Adjusts the amount of red in the color selected.



Phone Dial Dialog Box

Allows you to type your telephone number and dials the number. Check your modem instruction manual 
to see if you have to include extra characters (such as pauses for long distance access codes) in order to 
dial properly.



Tools Script Dialog Box

Enables you to select the login script you want to execute.

Directories
The directory under which your script file is stored.    In the listbox under Directories, you will see the path 
and all the directories in the path.

Drives
The drive in which your script file is stored.

File Name
The name of the login script you want to execute.

List Files of Type
Lists all the extensions of pertinent types of files.



Phone Phone Book Dialog Box

Click on the scroll bar to scroll through the sixty entries for remote computers. The default selection is the 
first host.    Select another host by clicking on it.    The selected host appears in the text boxes below the 
list box.

Click on individual controls to find out more information.



Modem Options Dialog Box

Sets modem and telephone variables.

Click on individual controls to find out more information.



Preferences Dialog Box

Sets scroll buffer pages, journal and beep on operation successful.

Click on individual controls to find out more information.



Speech Tools Dialog Box

Sets speech variables and filters.

The Speech Tools dialog box includes the following areas:

Mode
Sets how your received data will be read aloud.

Pitch
Sets the frequency range of the voice.

Speed
Sets how fast the words will be spoken.

Volume
Sets how loud the sound is.



Custom Modem Dialog Box

Enables you to set the modem command codes (from your computer to the modem) and the response 
codes (from the modem to your computer).    Check your modem manual to set up these codes.

Click on individual controls to find out more information.

 



File Open Dialog Box

Opens and installs a previously saved set of communications parameters.

The File Open dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file is stored.

File Name
Click on the file from which the data will be retrieved.

List Files of Type
Lists all the extensions of pertinent types of files.



File Page Setup Dialog Box

Enables the setup of the following printer options, which depend on your printer(s):

Orientation
Selects a normal portrait or landscape (printed lengthwise) paper orientation.

Paper Size
Selects the paper size.

Paper Source
Selects the source, such as manual feed, of the paper.

Printer
Selects of the printer from those you have enabled.



File Save As Dialog Box

Saves communications parameters in a file you designate. You should use the .ATI extension.

The File Save As dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Transfer Receive Text Dialog Box

Starts the capturing process.

The Transfer Receive Text dialog box includes the following areas:

Directories    
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name 
Type a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Transfer Send Text Dialog Box

Enables you to select a text file to send.

The Transfer Send Text dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file is stored.

File Name
Click on the name of the file to be sent.

List Files of Type
Lists all the extensions of pertinent types of files.



Transfer Send Protocol Dialog Box

Enables you to send a file (or files) by using a protocol, and initiates the sending process.

The Transfer Send Protocol dialog box includes the following areas.

Directories
Click on the directory you want.

Drives
The drive in which your files are stored.

File Name
Select the file or files to be sent.

List Files of Type
Lists all the extensions of pertinent types of files.



Phone Book Load Dialog Box

Opens and installs a previously saved phone book or opens an empty phone book with a new name.

The Phone Book Load dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file is stored.

File Name
Select the file from which the Phone Book entries will be retrieved.

List Files of Type
Lists all the extensions of pertinent types of files.



File Print Dialog Box

Enables you to start printing incoming data or the contents of the terminal window and enables you to set 
print options.

The File Print dialog box includes the following areas:

Capture to Printer
If checked, enables printing data from the window or, if not checked, enables printing continuous data 
from the serial port.

Copies
Enables the selection of the number of copies to print.

Print Quality
Depending on your printer, you can get high, low or medium quality printouts.

Page Range
Selects for printing all buffer pages, just the text selected, or the current buffer page.

Print to File
Stores files for subsequent spooling with an MS-DOS command.

Printer
Names the printer selected in the File Print Setup dialog box.

Printer (button)
Enables access to the File Print Setup dialog box.



Tektronix File Print Dialog Box

Enables the user to configure a printer for a particular print job.

The Tektronix File Print dialog box includes the following areas:

Collate Copies
Enables or disables the sorting of copies.

Copies
Enables the selection of the number of copies to print.

Print Options
Selects stretching or scaling options.

Print Quality
Depending on your printer, you can get high, low or medium quality printouts.

Print to File
Stores files for subsequent spooling with an MS-DOS command.

Printer
Names the printer selected in the File Print Setup dialog box.

Setup
Enables access to the File Print Setup dialog box.



Transfer Set Directory Dialog Box

Enables the selection of a directory/drive in which you will receive files. 

The Transfer Set Directory dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be saved.



Transfer Receive Protocol Dialog Box

Enables the selection of the name of the file to be received, and initiates receiving with a protocol.

The Transfer Receive Protocol dialog box includes the following areas.

Directories
Click on the directory you want.

Drives
The drive in which your file will be saved.

File Name
Select file name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Phone Book Save Dialog Box

Saves a phone book in a file with the extension .ATP.

The Phone Book Save dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your phone book will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Transfer Command Dialog Box

Enables the selection of the ZMODEM command to be sent to the host.



Transfer Kermit Get Dialog Box

Enables the selection of the file to receive from a Kermit Server.



File Append Selection To Dialog Box

Appends selected text to an existing file.

The File Append Selection To dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file is stored.

File Name
Click on the file to which the data will be appended.

List Files of Type
Lists all the extensions of pertinent types of files.



File Save Selections As Dialog Box

Saves selected text to a new file.

The File Save Selection As dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Tools Auto Script Dialog Box

Creates a login script as you log in, and saves it to a new file.

The Tools Auto Script dialog box includes the following areas:

Directories
Click on the directory you want.

Drives
The drive in which your file will be stored.

File Name
Type in a name under which your file will be saved.

Save File as Type
Lists all the extensions of pertinent types of files.



Edit Add Share Dialog Box

Enables an A-Talk DDE server to share information on a network.

The Edit Add Share dialog box includes the following areas:

Application
This entry is always ATalk and cannot be changed.

Item
References, in R1C1 format, the screen area that you have selected.

Overwrite Current Share
Enables the cancellation of an existing share.

Password
Enables the user to enter one or two passwords.

Permissions
Selects access types that can be associated with each password.

Share Name
The name of the share you want to create. You should use names that end with a dollar sign ($).

Topic
This entry is always Screen and cannot be changed.



Edit Link To Share Dialog Box

Enables an A-Talk DDE client to obtain information from another computer on a network.

The Edit Link To Share dialog box includes the following areas:

Computer
Brings up the Select Computer Dialog Box, which will enable you to select an available computer on your 
network.

Computer Name
The name of the computer that contains the share to which you want to link.

Item Name
References the item from the computer that contains the share to which you want to link.

Local Item Name
References, in R1C1 format, the initial row and column of the screen area that you have selected and 
want to link to the remote share item.

Share Name
The name of the share to which you want to link.



Edit Unlink from Share Dialog Box

Enables an A-Talk DDE client to cancel hot links to shares on other computers on a network.

The Edit Unlink To Share dialog box includes the following areas:

Item Name
References the item from the computer that contains the share from which you want to unlink.

Show Linked Share Items On
Enables selection of the item to be unlinked.    The computer name and share name appear above the 
item name in outline format.



Edit Remove Share Dialog Box

Stops an A-Talk Network DDE server from sharing information on a network.

The Edit Remove Share dialog box includes the following areas:

Shares
This list box enumerates all the currently active A-Talk shares on the system.



A-Talk Keys

Choose from the following list to review the keys used in Windows and A-Talk:

Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



A-Talk Commands

To get help with a command, choose the appropriate menu.

File Menu Commands
New
Open
Save
Save As
Save Selection As
Append Selection To
Print
Print Setup
Exit

Edit Menu Commands
Cut
Copy
Paste
Send
Send To
Select All
Clear
Add Share
Link to Share
Unlink from Share
Remove Share

View Menu Commands
Timer
Status Bar
Toolbar
Split Window

Options Menu Commands
Communications
Modem
Text Transfer
Protocol Transfer
Terminal
Function Keys
VT SET-UP Keyboard
VT SET-UP Display
Font
Color
Speech
Preferences
Save Workspace on Exit
Smooth Scroll

Phone Menu Commands
Auto Script
Dial
Phone Book
Hangup
Send Break



AutoAnswer
Script
Script Editor
BBS

Transfer Menu Commands
Receive Protocol
Send Protocol
Receive Text
Send Text
Kermit Get/Command
Kermit Finish
Set Directory

Tektronix Menu Commands
Save Bitmap
Save Picture
Save Plot
Print
Replay



A-Talk Procedures

Settings Control
Changing the Colors of the Window
Loading Settings from ATALK.INI
Loading Settings from Existing .INI Files
Saving Control Codes in Incoming Text Files
Saving Settings to ATALK.INI
Saving Settings to Files
Selecting Flow Control for Text File Transfers
Setting Line and Character Delays
Setting Parameters for Communication
Setting Terminal Emulation
Setting Tektronix Emulation
Specifying Modem Commands

File Transfers
Dragging and Dropping Files
Receiving Binary Files
Receiving Mail as Text
Receiving Text Files
Sending Binary Files
Sending Mail as Text
Sending Text Files
Viewing Captured Text Files

Selected Text Control
Copying Text to the Clipboard
Selecting Everything in the Terminal Window
Selecting Text on Your Window
Sending Selected Text to a Host

Printing
Getting a Cheap Printout
Printing Incoming Text

Phonebook/Communication with Host
Adding a Host to the phonebook
Connecting to a Remote Computer
Creating a Login Script with Script Tutor
Creating a New Phone Book
Dialing a BBS
Dialing a Phone Number
Disconnecting from a Remote Computer
Loading an Alternate Phonebook
Using the Phonebook for Dialing

Tektronix
Replaying a Tektronix Plot
Saving a Tektronix Bitmap
Saving a Tektronix Picture
Saving in Tektronix PLOT-10 Format

Mail and Network DDE
Adding a Network DDE Share



Deleting a Network DDE Share
Inserting DDE Hot and Warm Links
Linking to a Network DDE Share
Sending a Message with MAPI or Microsoft Mail
Signing In to MAPI or Microsoft Mail
Unlinking from a Network DDE Share

Miscellaneous
Defining the Function Keys
Exiting
Installing A-Talk
Timing Terminal Sessions



Help About Command

Use this command to display the version number of your copy of A-Talk for Windows, the copyright notice,
installed math coprocessors, and the available disk space and memory.



Help Index Command

Use this command to display an index of all major A-Talk topics: menu commands, reference information, 
dialog boxes, keyboard usage and procedures. 



Help Contents Command

Use this command to display the opening screen of Help. From the opening screen, you can jump to step-
by-step instructions for using A-Talk and various types of reference information.

Once you open Help, you can click the first button on the left in the Help window whenever you want to 
return to the opening screen.



Help Search Command

Use this command to search for keywords in the A-Talk help file.



Help Using Help Command

Use this command to ask for more information on how to use the Windows help system.



Help Technical Support Command

Use this command to search for available technical support on A-Talk.



Help Keyboard Command

Use this command to display the use of various keys in Windows and A-Talk. 



Help Procedures Command

Use this command to display a list of activities that may be performed while using A-Talk. 



Help Commands Command

Use this command to display an index of all menu commands. 



Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.

End or Ctrl+Right Arrow Moves to the end of a field.

Home or CTRL+Left Arrow Moves to the beginning of a field.

PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).

SHIFT+TAB Moves from field to field in reverse order.

ALT+letter Moves to the option or group whose underlined letter matches the one 
you type.

DIRECTION key Moves from option to option within a group of options.

ENTER Executes a command button.
Or, chooses the selected item in a list box and executes the command.

ESC Closes a dialog box without completing the command. (Same as Cancel)

ALT+DOWN ARROW Opens a drop-down list box.

ALT+UP or DOWN ARROW Selects item in a drop-down list box.

SPACEBAR Cancels a selection in a list box.
Selects or clears a check box.

CTRL+SLASH Selects all the items in a list box.

CTRL+BACKSLASH Cancels all selections except the current selection.

SHIFT+ DIRECTION key Extends selection in a text box.

SHIFT+ HOME Extends selection to first character in a text box.

SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.

Or, deletes selected text.

Delete Deletes the character to the right of the cursor.

Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for A-Talk. If the Help window is 
already open, pressing F1 displays the "Using Windows Help" topics.

In A-Talk, pressing F1 displays a Help topic on the selected command, 
dialog box option, or system message.

SHIFT+F1 Changes the pointer to  so you can get Help on a specific 
command. You can then choose a command you want to know more 
about.



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.

Letter key Chooses the menu, or menu item, whose underlined letter matches the 
one you type.

Alt+letter key Pulls down the menu whose underlined letter matches the one you type.

LEFT or RIGHT ARROW Moves among menus.

UP or DOWN ARROW Moves among menu items.

Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Ctrl+Esc Switches to the Task List.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application. (See Help 
Keys)



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left or right.

SHIFT+DOWN or UP Selects one line of text up or down.

SHIFT+END Selects text to the end of the line.

SHIFT+HOME Selects text to the beginning of the line.

SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is already
selected.

SHIFT+PAGE UP Selects text up one window.

Or, cancels the selection if the previous window is 
already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.

CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or end 
(DOWN ARROW) of the paragraph.

CTRL+SHIFT+END Selects text to the end of the document.

CTRL+SHIFT+HOME Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.

ALT+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+ENTER Switches a non-Windows application between running in a window and 
running full screen.

DIRECTION key Moves a window when you have chosen Move from the Control menu.
Or, changes the size of a window when you have chosen Size from the 
Control menu.



Glossary

ack
alt key
ansi
application
ascii
asynchronous transmission
backspace
baud
bcc (block check character)
bel
bell 212
binary
bit
bitmap
bps
boot
box
buffer
byte
can (cancel)
carrier detect
channel
character
client
clipboard
command
communications protocol
console
conversation
carriage return
cyclic redundancy check
crt
cts (clear to send)
cursor
dde
default
del (delete key)
delete
desktop
dialog box
dibit
display
dos
downloading
drive
dsr (data set ready)
dte (data terminal equipment)
dtr (data terminal ready)
dumb terminal
emulation
enq (enquiry)
eot (end of transmission)
error detection



esc (escape)
etb (end of transmission block)
etx (end of text)
even parity
fdx (full duplex)
file
file name
flow control
function keys
glossary
handshaking
help
hdx (half duplex)
icon
item
kermit
load
mainframe
mark
menu
modem
multi-tasking
nak (negative acknowledgement)
null modem
operating system
packet
parity bit
parity check
password
pointer
port
protocol
public switched network
pulse dialing
ram (random access memory)
redundancy check
response time
rom (read-only memory)
rs-232
rts (request to send)
scroll bar
scroll
server
service/application
soh (start of header)
space
start bit
stop bit
tiff
topic
wildcard character
window
window border/corner
wxmodem
xmodem1k-xmodem



xon/xoff
ymodem-batch
ymodem-g
zmodem
zoom



Glossary

Portions of this glossary have been reprinted with permission from Black Box Catalog.



ACK

A control character sent to acknowledge that a transmission block has been received.



ALT keys (Alternative Keys)

Two keys at the bottom of the keyboard that work, like shift keys, when pressed with other 
keys.



ANSI (American National Standards Institute)

The principal standard development body in the U.S.A.    ANSI is a nonprofit, 
nongovernmental body supported by over 1000 trade organizations, professional societies 
and companies.    U.S.A.'s member body to ISO (International Standards Organization).



Application

A program running on the Desktop.    An application lets you create and change information.



ASCII (American Standard Code for Information Interchange)

Pronounced "as'kee".    A seven-bit-plus-parity code established by    ANSI to achieve 
compatibility between data services.



Asynchronous Transmission

Transmission in which time intervals between transmitted characters may be of unequal 
length.    Transmission is controlled by start and stop bits at the beginning and end of each 
character.



Backspace

The key with the left pointing arrow at the top right of the keyboard.    This key moves the 
cursor back, erasing data.



Baud

Unit of signaling speed.    The speed in baud is the number of discrete conditions or events 
per second.    If each event represents only one bit condition, baud rate equals bps.    When 
each event represents more than one bit (e.g. dibit), baud rate does not equal bps.



BCC (Block Check Character)

A character transmitted by the sender after each message block and compared with a block 
check character computed by the receiver, used to check transmission accuracy (e.g. CRC).



BEL

A control character that is used when there is a need to call for attention; it may control 
alarm or attention devices.



Bell 212

An AT&T modem-providing, full-duplex, asynchronous or synchronous, 1200 bps data 
transmission for use on the public telephone network.



Binary

Digital system with two states, one and zero; contrast with octal, decimal and hexadecimal. 
A binary file contains only ones and zeros, and is usually an executable program.



Bit (Binary Digit)

Contraction of binary digit, the smallest unit of information in a binary system; a one or zero 
condition.



Bitmap

A Windows software standard for interchanging graphics files among various programs. An 
image stored as a pattern of dots (or pels). BMP is a file extension for bitmap files.



BMP

A Windows software standard for interchanging graphic files among various programs. A file 
extension for bitmap files.



BPS (Bits Per Second)

Unit of data transmission rate.



Boot - To start a computer with a master program that will enable it to use other programs.



Box

A device, represented graphically on the window, which communicates with the program.    
You may type into a text box, click on a selection in a list box, or use the various buttons and
devices in a dialog box.



Buffer

A temporary-storage device used to compensate for a difference in data rate and flow 
between two devices (typically a computer and a printer); also called a spooler.



Byte

A binary element string functioning as a unit, usually shorter than a computer word.    Eight-
bit bytes are most common.    Also called a character.



CAN (Cancel)

A character indicating that the data preceding it is in error and should be ignored.



Carrier Detect

Same as Received Line Signal Detector.    An RS-232 modem signal that indicates to an 
attached terminal that the modem is receiving a signal from a remote modem.



Channel

All DDE communication between applications occurs on a private channel. The DDE Initiate 
function is used to open a channel and the DDE Terminate function is used to close a 
channel.



Character

Letter, numeral, punctuation, control figure or any other symbol contained in a message.



Client

The application that initiates a DDE channel conversation.



Clipboard

The special holding area for text or other information. You may transfer the contents of the 
holding area from one application to another by cutting and pasting.



Command

Any instruction given to the computer, whether typed or selected from a menu.



Communications Protocol

The rules governing the exchange of information between devices on a data link.



Console

The device used by an operator, system manager or maintenance engineer to monitor or 
control computer, system or network performance.



Conversation

Two Windows applications using DDE to exchange data are in a "conversation".    The 
conversation is conducted though a channel.    The DDE client is the application that initiated
the conversation; the DDE server is the application that responds to the DDE client.



CR (Carriage Return)

An ASCII or EBCDIC control character that moves the cursor or print mechanism to the left 
margin.



CRC (Cyclic Redundancy Check)

An error-detection scheme in which the block check character is the remainder after dividing
all the serialized bits in a transmission block by a predetermined binary number.



CRT (Cathode Ray Tube)

A television-like picture tube used in a terminal; commonly used as a synonym for CA1 
terminal.



CTS (Clear to Send)
An RS-232 modem interface control signal which indicates that the attached DTE may begin 
transmitting.



Cursor Keys

Arrow keys (on the keypad) which move the cursor around on the screen.



DDE (Dynamic Data Exchange) 

A Windows protocol that allows two Windows applications to communicate with each other, 
allowing for the continuous and automatic exchange of data without user intervention.



Default

The option that will be executed unless the user specifies another option.



DEL (Delete Key)

A key at the top of the keyboard which moves the cursor backwards, deleting data.



Delete

The removal of data by the Delete or Backspace keys.



Desktop

A facility which allows you to perform various operations such as copying disks and opening,
closing and moving projects, applications and directories.



Dialog box

A graphic box which appears on the screen when extra information is needed by the 
program.    The user will type in the information or click to make selections.    Then the user 
will have to select a box or button (usually OK or CANCEL) to close the dialog box before 
proceeding.



Dibit

A group of two bits.    The four possible states for a dibit code are 00, 01, 10, and 11.



Display

To show an image on the monitor screen, or the monitor itself.



DOS

The disk operating system for the IBM PC.



Downloading

The process of sending configuration parameters, operating software or related data from a 
central source to remote stations.    



Drive

A hardware device (Floppy Disk Drive or Hard Disk Drive) for storing and retrieving data.



DSR (Data Set Ready)

An RS-232 modem interface control signal which indicates that the terminal is ready for 
transmission.



DTE (Data Terminal Equipment)

Devices acting as data source, data sink, or both.



DTR (Data Terminal Ready)

Modem interface signal which alerts the modem that the DTE device is ready for 
transmission.



Dumb Terminal

Both hard-copy and VDT type ASCII asynchronous terminals that do not use a data 
transmission protocol and usually send data one character at a time.



Emulation

The imitation of a computer system, performed by a combination of hardware and software, 
that allows programs to run between incompatible systems.



ENQ (Enquiry)

A transmission control character used as a request for a response from a remote station.



EOT (End of Transmission)

A transmission control character used to indicate the conclusion of the transmission of one 
or more texts.    



Error Detection

An arrangement that senses flaws in received data by examining parity bits, verifying block 
check characters or using other techniques. 



ESC (Escape)

1) A control character which is used to provide additional control functions.    It alters the 
meaning of a limited number of continuously following bit combinations.

2) The Escape Key, which interrupts certain procedures (such as Dial and Login).



ETB (End of Transmission Block)

A transmission control character used to indicate the end of a transmission block of data.



ETX (End of Text)

A transmission control character that terminates a text.



Even Parity

A dumb terminal data verification method in which each character must have an even 
number of on bits.



FDX (Full Duplex)

Simultaneous, two-way, independent transmission in both directions (4-wire).



File

A collection of related data on a disk or other mass storage.



File Name

The name used by the computer to call up or refer to a particular file.



Flow Control

The procedure for regulating the flow of data between two devices; prevents the loss of data
once a device's buffer has reached its capacity.



Function Keys

The user definable keys at the top of the keyboard. 



Handshaking

Exchange of predetermined signals between two devices establishing a connection.    Usually
part of a communications protocol.



Help

The support accessed by the Help Menu. Technical support is also available from New 
Horizons Software, Inc. at (512)328-6650 from 9AM to 5PM Central Time, Monday through 
Friday. 



HDX (Half Duplex)

Transmission in either direction, but not simultaneous (2-wire).



Icon

An image on the Windows Manager that represents a Disk Drive, Program, File, etc.



Item

A reference to a piece of data (such as an integer, a string, a range of cells in a worksheet, a
chart, or a bitmap) that can be passed between two applications engaged in a DDE 
conversation.



Kermit

Transfers information in packets of no particular size. Lost or garbled packets are detected 
and retransmission is requested. 

Enables the transfer of multiple files.

By default, Kermit strips the disk and directory names and converts the file name to capital 
letters (if you are sending a file from your PC to a host) or small letters (if you are receiving a
file from a host).



Load

To put a disk program into the computer.



Mainframe

A large-scale computer system that can house comprehensive software and several 
peripherals.



Mark

Presence of signal.    In telegraph communication, a mark represents the closed condition or 
current flowing.    A mark impulse is equivalent to a binary 1.



Menu

The list of available software functions for selection by mouse or Shortcut Keys.    A menu is 
displayed when you move the Pointer to the name of the Menu on the Menu bar and click 
the mouse button.



Modem (Modulator-Demodulator)

A device used to convert serial digital data from a transmitting terminal to a signal suitable 
for transmission over a telephone channel, or to reconvert the transmitted signal to serial 
digital data for acceptance by a receiving terminal.



Multi-tasking

The ability of a computer to run more than one program at a time.



NAK (Negative Acknowledgement)

A control character used to indicate that the previous transmission block was in error and 
the receiver is ready to accept retransmission.



Null Modem

A device that connects two DTE devices directly by emulating the physical connections of a 
modem.



Operating System

The software which runs the hardware devices (monitor, disk drives, etc.) and application 
programs.



Packet

A group of bits (including data and call control signals) transmitted as a whole on a packet-
switched network.    Usually smaller than a transmission block.



Parity Bit

A bit that is set at "0" or "1" in a character to ensure that the total number of 1 bits in the 
byte is even or odd.



Parity Check

The addition of noninformation bits that make up a transmission block to ensure that the 
total number of 1s is always either even (even parity) or odd (odd parity); used to detect 
transmission errors.



Password

A code word to ensure that a user's account (on a mainframe or network) remains private. 



Pointer

The arrow, or object, which moves on the screen as you move the mouse.    The Pointer is 
used for selecting icons and gadgets and for choosing menu items. 



Port

A computer interface capable of attaching to a modem for communication with a remote 
terminal.



Protocol

A formal set of conventions governing the formatting and relative timing of message 
exchange between two communicating systems.



Public Switched Network

Any switching communications system such as Telex, TWX or public telephone networks that
provides circuit switching to many customers.



Pulse Dialing

Older form of phone dialing, utilized in rotary dial phones. 



RAM (Random Access Memory)

Semiconductor read-write volatile memory.    Data stored is lost if power is turned off.



Redundancy Check

A technique of error detection involving the transmission of additional data related to the 
basic data in such a way that the receiving terminal, by comparing the two sets of data, can 
determine the probability that an error has occurred in transmission.



Response Time

The elapsed time between the generation of the last character of a message at a terminal 
and the receipt of the first character of the reply.    It includes terminal delay and network 
delay.



ROM (Read-Only Memory)

Nonvolatile semiconductor memory manufactured with predefined data content, 
permanently stored.



RS-232

Interface between data terminal equipment (computer) and data communication equipment 
(modem) employing serial binary data interchange.



RTS (Request to Send)

An RS-232 modem interface (sent from the DTE to the modem on pin 4) which indicates that
the DTE has data to transmit.



Scroll Bar

A gadget which you move to display previously hidden areas of a project.



Server

The application that responds to the DDE client.



Service/Application

The name of a Windows application that can accept a DDE conversation.



Scroll

To move through the contents of a project, displaying previously hidden areas.



SOH (Start of Header)

A transmission control character used as the first character of a heading of an information 
message.



Space

Absence of signal.    In telegraph communications, a space represents the open condition or 
no current flowing.    A space impulse is equivalent to a binary 0.



Start Bit

In asynchronous transmission, the first bit or element in each character, normally a space, 
which prepares the receiving equipment for the reception and registration of the character.



Stop Bit

In asynchronous transmission, the last bit, used to indicate the end of a character; normally 
a mark condition, which serves to return the line to its idle or rest state.



TIFF

A PC software standard for interchanging graphic and files among various programs.



Topic

Information that defines the "subject" of a DDE conversation and represents some unit of 
data that is meaningful to the DDE server application.    For most applications that operate 
on files, this is a file name. For A-Talk, meaningful topics are system, screen and buffer.



Wildcard Character

Characters such as "*" and "?" which are sometime used to designate groups of files that 
you would like to transfer all at once.    The "*" stands for any sequence of characters.    The 
"?" stands for any one character.



Window

A box, or area on the screen.    Applications and independently running programs use 
windows to accept and present information.



Window Border/Corner

By dragging the border or corner of the window with the mouse pointer, the user is able to 
change the size of a window.



WXMODEM

WXMODEM (Windowed XMODEM) is a modified version of the XMODEM protocol that 
provides greater speed in uploads and downloads. 



XMODEM

Transfers information in blocks of 128 bytes. The last block is padded with zeroes to make 
128 bytes. Multiple files cannot be transferred.    When sending or receiving a ZIP, ARC or 
ZOO file, select the Send or Receive option with Type Binary.



XON/XOFF (Transmitter On/Transmitter Off)

Control characters used for flow control, instructing a terminal to start transmission (XON) 
and end transmission (XOFF).



1K-XMODEM

Transfers information in blocks of 1,024 bytes.    This allows for faster transmission, unless 
your phone line has a lot of static.    Multiple files cannot be transferred.

1K-XMODEM is sometimes called YMODEM.



YMODEM Batch

Sometimes called True YMODEM. Transfers in blocks of 1,024 bytes.    Allows use of CRC-16.    

Information about each file is sent before each file transfer.    When sending a file from your 
PC to a host, do not include the file name with the receive command that you give to your 
host. Enables the transfer of multiple files.

CompuServe runs YMODEM Batch but calls it YMODEM. If you select YMODEM on 
CompuServe, you should select YMODEM Batch on A-Talk.



YMODEM-g

A high-speed modification of the YMODEM Batch Protocol; acknowledgements for data 
blocks are not used.    Because it does not use error-recovery, YMODEM-g must be used with 
hard-wired connection or with a hardware error-correcting modem.    When an error is 
detected, the transfer is aborted. 

Requires unidirectional flow-control to work at high speeds.    Works by sending an XOFF 
when the receiving input buffer is full; when an XON is received, transfer is resumed.    If your
host BBS supports the RTS/CTS handshake, it should be used in place of XON/XOFF for fast 
baud rates. 

Enables the transfer of multiple files.



ZMODEM

Like YMODEM Batch (transfers in blocks of 1,024 bytes), but faster.    By acknowledging only 
the bad packets, transmission is speeded up. At 9600 baud you can transfer files at over 
1000 characters per second; at 19,200 baud you can receive to the RAM: disk at over 1500 
characters per second when using ZMODEM and the RTS/CTS handshake.

Enables the use of a more powerful CRC-32 as a transfer check.    Enables resumption of 
interrupted binary file transfers (when no text conversion option has been requested by the 
host ZMODEM). Supports remote commands from a host computer.    The ZMODEM remote 
host commands must provide their own windows if they need to do input/output on the PC.    
By default, this feature is turned off to protect your computer.

Enables the transfer of multiple files.



Zoom
This allows you to narrow in on a portion of the screen for a more detailed view.



Application Control Close Command

Closes an application window.

Same as File Exit

To choose this command, do one of the following:

- Double click the application System menu icon.
- Click the application System-menu icon, then click Close.
- Press Alt, Spacebar, C.
- Press Alt, F4.



Application Control Maximize Command

Expands an application to the full size of the screen.

Same as Application Control Restore when the window is fully enlarged.

To choose this command, do one of the following:

- Click the Maximize icon
- Click the application Control-menu icon, then click Maximize.
- Press Alt, Spacebar, X.



Application Control Minimize Command

Shrinks an application window to an icon.

To choose this command, do one of the following:

- Click the Minimize icon
- Click the application Control-menu icon, then click Minimize.
- Press Alt, Spacebar, N.



Application Control Move Command

Displays a four-headed arrow that you can use with the direction keys to reposition an 
application window. This command is unavailable if the window is enlarged to maximum 
size.

To choose this command, do one of the following:

- Click the application Control-menu icon, then click Move.
- Press Alt, Spacebar, M.



Application Control Restore Command

Returns a fully enlarged application window to its previous size.

Same as Application Control Maximize when the window is fully enlarged.

To choose this command, do one of the following:

- Click the Restore icon
- Click the application Control-menu icon, then click Restore.
- Press Alt, Spacebar, R.



Application Control Size Command

Displays a four-headed arrow that you can use with the direction keys to change the size of 
an application window. This command is unavailable if the window is enlarged to maximum 
size.

To choose this command, do one of the following:

- Click the application Control-menu icon, then click Size.
- Press Alt, Spacebar, S.



Application Control Switch To Command

Displays the Task List dialog box allowing you to:

- Select another application to which you want to switch the control (Switch To)
- End the current application (End Task)
- Select Cascade or Tile for windows (Cascade or Tile)
- Arrange Icons

To choose this command, do one of the following:

- Click the application Control-menu icon, then click Switch To.
- Press Ctrl, Escape.



Terminal Window

The A-Talk terminal window displays the data received from host computers.



Maximize Icon

Located at the right end of title bars in application windows that are not fully enlarged.

Clicking the maximize icon is the same as choosing Application Control Maximize: the 
application window enlarges to fill the screen. Maximized windows have no borders.

Related topics
Minimize icon



Minimize Icon

Located at the right end of the title bar in an application window. 
Clicking the minimize icon is the same as choosing Application Control Minimize: the 
application window shrinks to an icon.

Related topics
Maximize icon



Sizing Border

Borders appear on windows that are not enlarged to maximum size. 

You can drag a window's border to make the window larger or smaller.
- Drag top, bottom or side border to size in one direction only.
- Drag a corner of the border to size both vertically and horizontally.

Related topics
Application Control Size command



System Menu Commands

Affect application windows.
To display the application System menu, do one of the following:

- Click the application Control-menu icon
- Press Alt, Spacebar

Close Closes an application window
Maximize Expands an application window to the full size of the screen
Minimize Shrinks an application window to an icon
Move Displays a four-headed arrow you can use with the direction keys to reposition
an application window
Restore Returns the active window to its previous size
Size Displays a four-headed arrow you can use with the direction keys to change 
the size of an application window
Switch To Switches control to another application



Title Bar

Located along the top of a window.

Drag the title bar to move the window. Dialog boxes with title bars can also be moved this 
way.

A title bar may contain:
Application System-menu
Maximize icon
Minimize icon
Name of connected host
Clock
Restore icon



Restore Icon

Located at the right end of the title bar in a maximized application window. 
Clicking the restore icon is the same as choosing Application Control Restore: the application
window returns to its previous size.

Related topics
Maximize iconMinimize icon



Baud Rate

The speed at which data is transmitted.    The rate you choose depends on your modem and 
the remote host or micro.

 When two computers are connected directly with a null modem cable, you should be able to
use 9600 baud or more.



Duplex

Refers to whether or not the remote computer will echo commands typed on your PC.

Select the Duplex option for more information.

Full The host will echo commands on your PC.
Half The host will not echo commands on your PC.



Handshake

Delays the transmission of data to prevent loss.

Choose the XON/XOFF handshake with Kermit and with Transfer Receive/Send Text and in 
terminal emulation.    Do NOT choose the XON/XOFF handshake with XMODEM, 1K-XMODEM, 
YMODEM-g or YMODEM Batch protocols.    If your host supports it, choose the RTS/CTS 
handshake for ZMODEM transfers.    Otherwise, use XON/XOFF.



No. Bits

The number of bits per byte.    Most hosts accept either 8 bits no parity or 7 bits even parity.  
Most BBS's require eight bits.    For a binary file, you must use 8 bits, no parity, unless you 
are using Kermit.



Parity

 Refers to whether the sum of the zeroes and ones in a byte will be odd or even.

Most BBS's require None. For transmission of binary files, use 8 bits, no parity, unless you 
are using Kermit.

Select the Parity option for more information.

Even The sum of the bits in the byte will be even.
Mark A "1" is added as the eight bit.
None No extra bit.
Odd The sum of the bits in the byte will be odd.
Space A "0" is added as the eight bit.



Port

Select a port from COM1: to COM4: if you have multiple serial ports.



Stop Bits

The number of bits between bytes.    At 300 baud, choose two bits.    Most BBS's require one 
stop bit.



Line Type

Choose Pulse (for rotary dial lines) or Touch (touch tone) depending on what type of 
telephone line you have.



Modem Type

Select your modem type from the list box.    

If your modem is not listed and is a Hayes compatible, select Hayes Compatible Modem 
or Custom Modem. If you have selected Custom Modem, you may click on the Custom 
modem button. 

If your modem is not listed and not Hayes compatible, you may select Generic modem.



Modem Initialization String

This is a sequence or string of commands that selects a particular modem configuration 
before dialing. The parameters set are those such as modem register values, flow control 
and modem selection.



Redial

Choose 10 Times or Continuously if your host is difficult to reach.

After a number of seconds, depending on the type of modem and the length of the dialing 
string, there will be a timeout, then a delay of 5 seconds, after which the next redial will be 
triggered.    The length of the redial timeout (delay) can be programmed in the Phone Book.



Phone Book Options Buttons

Enable access to other dialog boxes.

For more information, select an option button.

 Comm Button Enables access to the Communications options dialog box.
Fkeys Button Enables access to the Function Keys options dialog box.
Modem Button Enables accesss the Custom modem dialog box.
Protocol Button Enables access the Protocol Transfer options dialog box.
Terminal Button Enables access to the Terminal options dialog box.
Text Button Enables access to the Text Transfer options dialog box.



Text Button

Enables access to the Text Transfer Options dialog box. 

Set all the Text Transfer options for a particular host by first clicking on that host and then on
the Text button.    You can set receive, send, line delay and character delay.

See Also
Text Transfer Options Dialog Box



Custom Button

Accesses the Custom Modem dialog box.

Enables you to set the modem command codes (from your computer to the modem) and the
response codes (from the modem to your computer).    Check your modem manual to set up 
these codes.

See Also
Custom Modem Dialog Box



FKeys Button

Enables access to the Function Keys options dialog box,which lets you define forty-four 
function keys: F5 through F12; the shifted keys F1 through F12; F1 through F12 with the 
control key; and F1 through F12 with the shift as well as the control key.    

See Also
A-Talk Keys
Options Function Keys Dialog Box



Comm Button

Enables access to the Communications Options dialog box.

To set options for a particular host, click on that host and then on the Comm button.    This 
dialog box is a fast way to set baud rate, stop bits, number of bits, handshake, duplex, parity
and port.    

See Also
Options Communications Dialog Box



Terminal Button

Accesses the Terminal Options dialog box.

First click on the host and then on the Terminal button. This dialog box is a fast way to set 
terminal emulator and bell.    

See Also
Options Terminal Dialog Box



Protocol Button

Accesses the Protocol Transfer Options dialog box.

First click on the host and then on the Protocol button. This dialog box is a fast way to set 
protocol, binary or text, timeouts, CRC, and remote commands OK.    

See Also
Options Protocol Transfer Dialog Box



Phone Book Text Boxes

The text boxes under the list box provide pertinent information about the host:    system 
name, phone number, a comment, etc.

For more information, select a subject.

Delay Seconds of delay between each redial.
Format General formatting information for all text boxes.
Long Distance Code For telephone access codes.
Queue How to link one host to another.
Script File The name of the script login file.



Phone Book Dial Button

After selection of the host, the Dial button dials the phone number of the selected host. 
Double-clicking on the host is equivalent to selection and dialing.



Phone Book Edit Buttons

These buttons allow you to modify phone book entries, install and save phone books.

For more information, select a subject.

Add Enables addition of new phone book entries.
Delete Removes phone book entries.
Load Installs alternate phone books.
Save Saves the current phone book.



Add Button

Enables the additions of new entries to the first empty line in the host list box.

After entering new host information in the various text boxes, remember to click on the 
Save button.

See Also
Adding a Host to the Phone Book



Delete Button

Enables the deletion of an entry from the selected line in the list box.

After deleting the entry, remember to click on the Save button.

See Also
Deleting a Host from the Phone Book



Load Button

Enables the installation of alternate phone books. Each loaded phone book is limited to 60 
entries, but there is no limit to the number of alternate phone books.

See Also
Loading an Alternate Phone Book
Creating a New Phone Book



Save Button

Enables you to save edited host data in phone books. Each loaded phone book is limited to 
60 entries, but there is no limit to the number of alternate phone books. 



Advanced Settings

When the Kermit protocol is selected, the Advanced Settings group box will show two 
buttons, Protocol and Packets, that bring up separate dialog boxes.

When the ZMODEM protocol is selected, the Advanced Settings group box will show two 
buttons, Send and Receive, that bring up separate dialog boxes.

See Also
Receiving Binary Files with Protocols
Receiving Text Files with Protocols
Sending Binary Files with Protocols
Sending Text Files with Protocols



CRC

A more accurate check of the transfer than checksum, CRC (cyclic redundancy check) can be
used for 1K-XMODEM, YMODEM Batch, YMODEM-g and ZMODEM.

XMODEM is checked in groups of eight bits (checksum).    1K-XMODEM,YMODEM Batch and 
YMODEM-g are checked in groups of sixteen bits (CRC-16). ZMODEM is checked in groups of 
thirty-two bits (CRC-32). The larger the number of bits used for the cyclic redundancy check, 
the faster and more accurate the protocol. 

See Also
Receiving Binary Files with Protocols
Receiving Text Files with Protocols
Sending Binary Files with Protocols
Sending Text Files with Protocols



Protocol

Various error-checking methods of transfer.

Even a small amount of static on the telephone line may garble the transfer unless a 
protocol is used to ensure reliable transmission.

Select the Protocol option for more information.

Kermit
Transfers information in packets of no particular size.

WxMODEM
Like XMODEM (transfers in blocks of 128 bytes), but faster.

XMODEM
Transfers information in blocks of 128 bytes.

1K-XMODEM
Transfers information in blocks of 1,024 bytes.

YMODEM Batch
Allows multiple file transfers in blocks of 1,024 bytes.

YMODEM-g
For hard-wired connection or a hardware error-correcting modem.

ZMODEM
Like YMODEM Batch (multiple file transfers in blocks of 1,024 bytes), but faster.

See Also
Receiving Binary Files with Protocols
Receiving Text Files with Protocols
Sending Binary Files with Protocols
Sending Text Files with Protocols



Remote Commands OK

Used with ZMODEM, enables support of remote commands from a host computer, generally 
a UNIX based system or another PC running A-Talk.    ZMODEM commands can be sent and 
received by A-Talk.

The ZMODEM remote host commands must provide their own windows if they need to do 
input/output on the PC.    By default, this feature is turned off so someone cannot send 
destructive commands that do damage to your computer.



Timeouts

Use Standard timeouts with Bulletin Boards (timeouts about every 10 seconds), and 
Relaxed with public networks (timeouts about every 23 seconds). If you notice that a 
transfer aborts with no indication of the type of error, it is probably a timeout error.    In this 
case choose the Relaxed option and retry the transmission.



Type

Select the type of transfer: binary or text. Use binary for the transfer of executable programs
or for the transfer of text files that require no translation (for example, between two PCs).    
Use text for    the transfer of text files that require the LF-->CR/LF translation (for example, 
receiving UNIX files). 

When using ZMODEM and all YMODEMs, the type should be set to binary when receiving 
both text and binary files from MS-DOS or CPM-based bulletin boards.    When transferring 
text files with Kermit between a PC and UNIX, the transfer type should be set to text since 
the PC and UNIX use different end-of-line characters. CompuServe B+ automatically 
recognizes the file type.



Scroll Buffer Pages

The scroll buffer is temporary storage for incoming data after it scrolls off the top of the 
screen.    You can move back and forth within the number of pages designated for the scroll 
buffer by using the vertical scroll bar.

See Also
Smooth Scroll



Beep on Operation Successful

This selection enables you to get a beep instead of a dialog box when an operation has been
successful.



Use Journal When Dialing

This selection enables you to create a log with the dates, times, system names and 
telephone numbers of your connections and disconnections from host computers.



Receive

Refers to how computers store the end of line characters in their files (line feed, carriage 
return or line feed + carriage return).    For no translation, select Plain.

This chart will help you choose your options.

These are the Text Transfer Receive options if you are receiving from:

MS DOS Keep CR/LF
Windows Keep CR/LF
Macintosh CR->CR/LF
Apple II CR->CR/LF
Networks Keep CR/LF
Amiga LF->CR/LF
UNIX LF->CR/LF



Char Delay

Use this to slow transmission character by character.    Choose delays from .05 to .2 of a 
second. 



Line Delay

Use this to    put a delay at the end of each line.    Useful for hosts that pause to scroll at the 
end of the line.    Choose a delay of .25 (one quarter of a second) to one second.



Send

Refers to how computers store the end of line characters in their files (line feed, carriage 
return or line feed + carriage return). This chart will help you select your options.

These are the Text Transfer Send options if you are sending to:

MS DOS CR/LF
Windows CR/LF
Macintosh CR only
Apple II CR only
Networks CR only
Amiga LF only
UNIX LF only



Auto LF/CR

Makes the "Return" key function like that of a typewriter: both a carriage return and a line 
feed will be generated.    When a line feed code is received, both a carriage return and a line 
feed will be generated.    When turned off, the "Return" key will generate only a carriage 
return; when a line feed code is received, only a line feed will be generated.

If you are getting double line feeds, turn this feature off.



Auto Wrap

By default, Auto Wrap is off.    That means there will be no carriage return after the last (80th
or 132nd) character on the line is typed; the last character will be constantly overwritten.    
When Auto Wrap is on, the 81st or 133rd character will go to the following line.



Columns

Choose 80 or 132 characters per line for the VT100 terminal mode.    When changing from 
one column mode to the other, the current contents of the screen are lost.



Cursor

Choose whether the cursor will be displayed or not.    The cursor will not be visible with the 
Blanked position.



Cursor Type

Gives a choice of two cursor representations, either a blinking Underline (_) or a Block.



Line State

Enables an on-line or off-line (local) condition. When in Line, all typed characters are sent to
the host and all messages from the host are displayed. With Local, messages are not sent 
or received from the host computer.



Margin Bell

Gives you a bell as in a typewriter.    You hear the bell when the cursor is eight characters 
from the end of the line.



Screen

Gives you two choices for the look of the screen. Normal means there are light characters 
on a dark background. Reverse gives you dark characters on a light background.



Scroll

Gives you two choices for the vertical movement of lines on the screen. Jump means that 
new lines appear as fast as they are sent even if the movement makes the lines difficult to 
read.    Smooth slows the appearance of new data, making it easy to read.



Answerback Message

Used in conjunction with the Auto Answer option, it refers to a question/answer sequence 
which identifies your terminal to the host. Type the Answerback Message into the text box.



Auto Answer

If you select this option, your Answerback Message will automatically be sent to the host, 
when requested.



Backspace Mode

Useful for VMS EDT users, choose Backspace if you want the backspace key to send a 
backspace and the Del key to send a delete.    Choose Delete if you want the Del key to 
send a backspace and the backspace key to send a delete.



Cursor Keys

When using VT100, you can have the cursor (arrow) keys send Normal escape sequences or
Application escape sequences.



Keypad

The keypad, or small group of keys usually on the right of the keyboard, can be used either 
as numbers or application keys when using the VT220, VT100, VT52, or H19.    With the 
Numeric selection, numbers typed from the keypad are indistinguishable from numbers 
typed from the top number row.    With the Application selection, the keys will transmit 
escape sequences. 



VT200 Mode

Sets terminal for either 8-bit controls (used in VT220 emulation only) or 7-bit controls (used 
in VT220 or VT100 emulation). To use 8-bit controls, you must set your communication 
options to 8-bit, no parity.



Bell

Audio or visual bell. 

Select the Bell option for more information.

Audio The PC speaker provides the beep.
Visual The menu bar flashes.



Terminal Emulator

Several possible emulators.

The emulator you choose depends on what your host supports.    You should use TTY, or 
ANSI for bulletin board systems; use CompuServe VIDTEX, VT`100 with CompuServe; use
DEC VT220, VT100, DEC VT52 or Zenith H19 with minis or mainframes.    Use Tektronix 
4014 (Tektronix 4010/14) for connecting to mini or mainframe hosts that support Plot-10 
graphics programs.

Select the Terminal Emulator option for more information.

ANSI IBM ANSI.SYS color compatible terminal.
CompuServe Similar to VT52.
DEC VT52 An old full-screen Digital Equipment Corp. terminal.
DEC VT100 A popular full-screen Digital Equipment Corp. terminal.
DEC VT220 A newer full-screen Digital Equipment Corp. terminal.
Tektronix 4014 Tektronix terminal for Plot-10 graphics programs.
TTY Works like a regular teletypewriter.
Zenith H19 A Heath terminal.



Use Function and Ctrl Keys for Windows

This selection allows you to decide whether the F1 key, the delete and the control keys perform as the 
Windows Help key and menu accelerators or as the terminal emulator PF1 key and Ctrl keys. 

When the checkbox is selected, the Ctrl+X, Ctrl+C, Ctrl+V, Ctrl+A and Del keys are used as accelerators 
for the Edit menu; the Ctrl+N, Ctrl+O, Ctrl+S, and Ctrl+P keys are used as accelerators for the File menu; 
the F1 key is used for Windows Help. Context-sensitive help is available.

When the checkbox is not selected (default behavior), the CTRL+SHIFT+X, CTRL+SHIFT+C, 
CTRL+SHIFT+V, CTRL+SHIFT+A and CTRL+SHIFT+Del keys are used as accelerators for the Edit 
menu; the CTRL+SHIFT+N, CTRL+SHIFT+O, CTRL+SHIFT+S, and CTRL+SHIFT+P keys are used as 
accelerators for the File menu; the F1 key is used to emulate PF1. All unshifted control keys function as 
emulator keys. Context-sensitive help is not available.



Courier HST Modem

Optimum performance is obtained with RTS/CTS handshake, and 9,600 baud or more.

With a baud rate of 9,600 or 19,200 baud, the modem is initialized for optimum performance
when the remote modem is an identical Courier HST modem.

Higher rates than 19,200 might be sustainable without errors only on newer PCs which 
support buffered serial chips, such as the 16550 UART.

With high speed modems, the DSR interface signal must be active at all times for the serial 
device to properly set RTS/CTS handshaking.    With a Hayes-compatible modem, DSR can be
made active with the command:

                                                          AT&S0&W



Generic Modem

The Generic option works if your modem asserts the carrier detect signal on pin 8 of the 
serial cable. If not, dial manually.



Telebit T1000 Modem

With a baud rate of less than 9,600 baud, the modem is initialized to connect to V.22bis 
(2400 baud) or 212A (1200 baud) standard modems, without using data compression, MNP 
or PEP mode.

At speeds of 9600 or higher, the Telebit modems will try to use PEP mode; if the host modem
does not support PEP mode, the transmission will be downgraded to 2400 baud or lower. 

The Telebit T1000 should be set up in Conventional Command Mode for speeds of less than 
9,600 baud, and in Enhanced Command Mode for 9,600 and 19,200 baud. Higher rates than 
19,200 might be sustainable without errors only on newer PCs which support buffered serial 
chips, such as the 16550 UART.

With high speed modems, the DSR interface signal must be active at all times for the serial 
device to properly set RTS/CTS handshaking.    With a Hayes-compatible modem, DSR can be
made active with the command:

                                                          AT&S0&W
The host will retransmit each command back to your PC.    Also called "local echo off".



The host receives but does not echo your command; your PC makes it appear on your 
monitor.    Also called "local echo on".



As the eighth bit, either a "0" or a "1" will be added to the sum of the first seven bits to 
make an even number.



As the eighth bit, a "1" is always added no matter what the sum of the first seven bits is.



No extra bit is added to the byte.    Most BBS's require None.



As the eighth bit, either a "0" or a "1" will be added to the sum of the first seven bits to 
make an odd number.



As the eighth bit, a "0" is always added no matter what the sum of the first seven bits is.



Seconds of delay between each redial.



This is a 35-character text box for telephone access codes such as those used by MCI, PC 
PURSUIT or SPRINT.    For example:

1-800-347-6578W-12345-617-920-2050

The first part is the access code.    The "W" is the Hayes command that waits for a dial tone.   
Then comes the phone company card secret access code and home phone number.    The 
phone number of the host you are calling goes in the Phone Number text box.



The number that precedes each entry in the Phone Book is used to link one host to another.   
If a host is busy, the next host in the Queue box will be tried.    Circular lists are allowed 
(1>2>3>1).



Contains the name of the script login file.    Before using the Phone Book dialog box for 
automatic login, you have to write a login script.



The built-in PC speaker or optional audio equipment will provide the audio bell. 



If you do NOT have a PC with a speaker or don't like a beep, you should use the visual bell, 
which appears as a flash on the menu bar.



ANSI

Your terminal can support escape sequences such as clear screen, erase line and cursor 
movement as defined by the American National Standard Code for Information Interchange.  

ANSI can use up to 8 colors and supports bold face and italics.    It can be used with IBM PC 
based bulletin boards such as OPUS. It provides FULL support of all IBM PC ANSI escape 
codes when selecting ANSI Terminal and WinANSI Font.    

For complete emulation of the IBM CGA, the following colors should be used:
R G B

___________________________________
Color 1: Black 0 0 0
Color 2: Red 255 0 0
Color 3: Green 0 255 0
Color 4: Yellow 255 255 0
Color 5: Blue 0 0 255
Color 6: Magenta 255 0 255
Color 7: Cyan 0 255 255
Color 8: White 255 255 255

Note:    If you use the WinANSI font and the above 8 colors, A-Talk will completely emulate 
the IBM ANSI.SYS screen device driver, including IBM-PC graphics characters.



DEC VT52

The VT52 terminals is fully supported, including alternate keypads and graphics fonts. Set 
Auto-Wrap On when using vi or emacs on UNIX.



DEC VT100

The DEC VT100 is a very popular full-screen editor.    Select this also for VT102.

The A-Talk VT100 emulator will support these fonts:    USA (sometimes called ASCII), UK, 
special graphics in both 80 and 132 characters per line.    Double height and double 
width characters are not supported.    

The Select Character Set (SCS) command can be invoked as follows:

G0 Sets G1 Sets Selects
Sequence Sequence Set
_____________________________________________
ESC ( A ESC ) A National
ESC ( B ESC ) B National/UK
ESC ( 0 ESC ) 0 National Special Graphics

The default character set is the National character set.

Supports the numeric and application mode escape sequences for the keypad keys.    The 
VT100 four function keys (PF1 through PF4) are emulated by the F1 through F4 PC keyboard 
keys.



DEC VT220

The DEC VT220 is a very popular and more recent full-screen editor. It includes all features 
of a VT100 plus additional support for function keys and 8-bit data.

The DEC VT220 function in 7 or 8-bit mode. The default is 8-bit mode. The DEC VT220 PF1 
through PF4 keys are supported.    The VT220 four function keys (PF1 through PF4) are 
emulated by the F1 through F4 PC keyboard keys. The DEC VT220 F6 though F 20 keys are 
also supported, depending on your keyboard. Standard IBM-type 101-key enhanced 
keyboards only support function keys up to F12. 

The A-Talk VT220 emulator will support these fonts:    USA (sometimes called ASCII), UK, 
special graphics in both 80 and 132 characters per line.    Double height and double 
width characters are not supported.    



Tektronix 4014

Select this option if you want to emulate the Tektronix 4010/4014.    Once you have made 
the selection, the Tektronix windows will be displayed.    



TTY

Works like a regular teletypewriter. It provides support for backspace, delete, carriage return
and line feed.



Zenith H19

The H19 terminal is fully supported, including alternate keypads and graphics fonts.



CR Effect

Enables selection of the function of the carriage return.

CR sends a carriage return in response to a carriage return. CR->LF, like a typewriter, sends
a carriage return and a line feed in response to a carriage return.



DEL

Enables selection of the function of the delete character.

DEL gives you a normal delete character. DEL->LOY lets the logic interpret the delete 
character or the escape ? sequence as a code to position the graphics cursor.



GIN Terminator

Enables selection of what follows the crosshair cursor position.

GIN mode is when the host puts up a large crosshair cursor.    The crosshair position is 
transmitted to the host in GIN mode and is followed by a GIN terminator.

None means no GIN terminator. CR means a carriage return. CR + EOT means a carriage 
return followed by an end of transmission.



LF Effect

Enables selection of the function of the line feed.

LF sends a line feed in response to a line feed. LF->CR, sends a carriage return and a line 
feed in response to a line feed.



Margin Control

Selects what happens when the cursor is at the last line on the screen and you receive a line
feed.

1 means you will get a beep. 2 means you will get a beep and the cursor will go into the 
second column on the screen. After finishing the second column, the cursor will go back to 
the first column on the screen. Off means you will not get a beep or a scroll.



Auto Answer

This string enables your modem to automatically answer incoming calls on your phone line. 
Most modems default to not answering calls automatically.



Busy

This means the modem has detected a busy signal on the telephone line.



Connected

This means that the modem has connected at a given BPS (bits per second). Modems that 
support multiple baud rates may connect to a host at a baud rate different from the rate 
between the modem and the computer.



Dial Pacing

Use this string to set the delay between characters in the dialing sequence. The delay is 
expressed in milliseconds (100 = 1/10 second).



Dialing Prefix

This string precedes the telephone number and it represents the modem command for 
placing a telephone call. For example, "ATDT" is the Hayes command for dialing with touch-
tone lines.



Dialing Postfix

This string follows the telephone number in a dialing sequence. An example of a postfix is 
^M, which stands for a carriage return.



Drop DTR

Use this string to indicate your modem accepts Drop DTR instead of the +++ATH Hayes 
command to hang up. When using any modem other than a Hayes-compatible, pin 20 (DTR) 
must be connected for the Drop DTR hang up to work,



Error

This string means the modem has detected an invalid command or the command line buffer 
has been exceeded.



Hang Up

This string is the command for hanging up the modem. A delay is expressed by a tilde (~). 
One tilde is equal to 3/10 of a second. Use three tildes for a delay of about a second.



Init

This is a sequence or string of commands that selects a particular modem configuration 
before dialing. The parameters set are those such as modem register values, flow control 
and modem selection.



No Carrier

This means the modem has detected a failure to connect or a loss or carrier. Most modems 
have a command that sets the maximum number of seconds they will wait for a carrier 
signal before giving this No Carrier message.



No Dialtone

The modem has not detected a dialtone. In order to get this message, most modems require
extra commands.



OK

This means the modem has acknowledged the successful execution of a command.



Ring

This means the modem has detected a ring signal (somebody is telephoning you).



Voice

This means the modem has detected a voice call instead of a modem call. 



Speech Mode

Selection of the speech mode will determine how data and characters are read aloud.    
Everything will read every received printable character; Filtered will read words with only 
the letters A-Z and the numbers 1-9; Messages will read only information, warning and 
critical messages; Off means there will be no reading aloud.



CompuServe VIDTEX

This is the standard terminal type on CompuServe and is similar to VT52. CompuServe B+ 
transfers are available only when using this terminal.



Loading Settings from ATALK.INI

To load settings from ATALK.INI:

* Select New from the File menu.



Loading Settings from Existing Initialization Files

To load settings from existing .ATI or .INI files:

1 Select Open from the File menu.
2 Choose the directory in the Directories list box of the File Open dialog box.
3 Choose the file in the Files list box or type a name in the File Name text box.
4 Choose OK.



Saving Settings to ATALK.INI

To save settings to ATALK.INI:

* Select Save from the File menu.



Saving Settings to Files

To save a settings file under a name for future use:
 
1 Select Save As from the File menu.
2 Choose the directory in the Directories list box of the File Save As dialog box.
3 Type a name in the File Name text box.
4 Choose OK.



Getting a Cheap Printout

To get a cheap printout:

1 Select Receive Text Start from the Transfer menu.
2 Type a file name under which you want to store your session.
3 After receiving, select Receive Text Pause or Stop.
4 You may now disconnect from your host.
5 For files that are 64K or smaller, use may use Receive Text View if you selected Pause. To Print, 

select File Print from the Notepad menu.
6 For files that are larger than 64K, open the received file with any Windows text editor and select File 

Print from the editor.



Selecting Text on Your Window

To select text:

1 Press the left mouse button.
2 Use the text cursor to move over the text you want to select. Selected text shows up in reverse video.
3 Release the left mouse button.



Copying Text to the Clipboard

To copy text to the clipboard:

1 Select text on your window the left mouse button.
2 Select Copy from the Edit menu.

See Also
Selecting Text on Your Window



Sending Selected Text to a Host

To send selected text to a host:

1 Select text on your windows with the left mouse button.
2 Select Send To Host from the Edit menu.

See Also
Selecting Text on Your Window



Selecting Everything in the Terminal Window

To select all text in the terminal window:

* Select Select All from the Edit menu.



Changing the Colors of the Window

To change the colors used for ANSI emulation:

1 Select Colors from the Format menu.
2 Choose one of the eight color boxes in the Format Colors dialog box.
3 Adjust the amount of Red, Green or Blue by using the controls.
4 If you do not like your changes, choose Reset to go back to the previous color adjustments.
5 Choose OK to save the new colors.



Defining the Function Keys

To define function keys:

1 Select Function Keys from the Options menu.
2 Choose the Modifier you want (none, shift, control, control/shift) from the Options Function Keys 

dialog box.
3 Choose the Key you want to define.
4 Type the definition you want in the String text box.    Use normal ASCII characters and the following 

control characters.

Type                                          To            

^M send a carriage return
^J send a line feed
^I send a horizonal tab
^H send a backspace
^[ send an escape
^Q send an X-on
^S send an X-off
^? send a delete

5 Choose OK.



Setting Parameters for Communication

To set parameters for communication:

1 Choose Communications from the Options menu.
2 Select the options appropriate for your system and the remote computer from the Options 

Communications dialog box. For binary transfers (except with Kermit) and communication with BBS's,
use 8 bits, no parity.

3 Choose OK.



Dialing a Phone Number

To dial a phone number:

1 Select Dial from the Phone menu.
2 Type a phone number in the Phone Dial dialog box.    Check your modem instruction manual to see if 

you have to include extra characters (such as pauses for long distance access codes).
3 Choose OK. You will get an error message if the line is busy or an error occurred.



Loading an Alternate Phone Book

To load an alternate phone book:

1 Make sure your alternate phone book extension is .ATP.
2 Select Phone Book from the Phone menu.
3 Choose Load in the Phone Book dialog box.
4 Select an existing phone book from the Phone Book Load dialog box.
5 Choose OK. 



Creating a New Phone Book

To create a new phone book:

1 Select Phone Book from the Phone menu.
2 Choose Load in the Phone Book dialog box.
3 Type a new name in the Phone Book Load dialog box. Make sure you give the new name a .ATP 

extension.
5 Choose OK.



Adding a Host to the Phone Book

To add a host to the phone book:

1 Select Phone Book from the Phone Menu.
2 Choose the Add button in the Phone Book dialog box.
3 Type in the name, phone number, and any other information into the text boxes below the list box.
4 Choose the Save button to the right of the list box.
5 Click on OK.

See Also
Deleting a Host from the Phone Book
Saving a    Phone Book



Using the Phone Book for Dialing

To use the phone book for dialing:

1 Select Phone Book from the Phone menu.
2 Set up the Phone Book dialog box.
3 Choose the host you want to dial.
4 Choose the Dial button.
5 To interrupt dialing, choose Cancel.

See Also
Adding a Host to the Phone Book
Deleting a Host from the Phone Book



Creating a Login Script with Auto Script

To create a login script:

1 Select the Auto Script command in the Tools menu.
2 Enter a name for your login script in the Auto Script dialog box.
3 Make sure the name you give for your login script has the extension .ATK.
4 Use Phone Dial to dial your host.
5 Login as usual.
6 Select End Auto Script.
7 Select Phone Book from the Phone menu.
8 Enter the script name in the Script text box in the Phone Book dialog box.



Sending Mail as Text

To send mail:

1 Use a text editor such as Notepad to write your mail message. 
2 Insert an end of transmission string.    How you do this depends on your host.
3 Save the mail message under a file name.
4 If you would like to change the default Text Transfer options, select Text Transfer from the Options 

menu.
5 The Options Text Transfer dialog box will appear. If appropriate, set the send options and the 

character and line delays.
6 Choose OK.
7 Login to your host.
8 Select the "Mail" command from the host's command set.
9 When asked by host to type a message, select Send Text from the Transfer menu.
10 Type in the name of the message file in the Send Text dialog box.
11 Choose OK.
12 Wait for the File Sent message box.
13 Log off from your host.

See Also
Setting Line and Character Delays



Receiving Mail as Text

To receive mail:

1 If you would like to change the default Text Transfer options, select Text Transfer from the Options 
menu.

2 The Options Text Transfer dialog box will appear. If appropriate, change the Receive options and the 
character and line delays.

3 Choose OK.
4 Select Text Transfer Receive Start from the Transfer menu.
5 Enter a file name in the Text Transfer dialog box.
6 Capture your session, including mail.
7 Select Receive Pause or Receive Stop from the Text Transfer menu.
8 Log off from the host.
9 If you have selected Pause, you may read your mail using View. Otherwise, you may read mail from 

the received file using an editor such as Notepad.

See Also
Setting Line and Character Delays
Viewing Received Text Files



Installing A-Talk

To install A-Talk:

1 Use your modem manual to connect your modem to a serial cable and to connect the serial cable to 
your computer - OR - connect two PCs with a null modem cable.

2 If you are using a modem, use your modem manual to set the switches inside the modem.
3 Start Windows.
4 After Windows comes up, insert the A-Talk Setup disk.
5 Choose the File Run command from the Program Manager.
6 Type A:\SETUP in the command line string box. Click on OK.
7 The A-Talk Setup dialog box will ask you where to install A-Talk.
8 After you have made your selections, choose Continue.
9 Check to see if there is an "A-Talk Readme" icon in A-Talk group. In this file you will find news and 

updates. View this information by double-clicking on it.
10 To run A-Talk, double-click on the A-Talk icon.



Dialing a BBS

To dial a BBS:

1 Select Communications from the Options menu.
2 The default parameters are already set up for communication with electronic bulletin boards.    
3 Choose the baud rate, which depends on your modem.
4 Choose OK.
5 Select Modem from the Options menu.
6 Select your Line Type, Pulse or Touch from the Options Modem dialog box.    It is also assumed you 

are using a Hayes compatible modem.    If not, choose your modem from those shown.
7 Choose OK.
8 Select Dial from the Phone menu.
9 Type the telephone number of the electronic bulletin board in the dialog box (if necessary, include 

extra characters for pauses for long distance access codes).
10 Choose OK.
11 If the line is busy, you will get a timeout or error message.
12 Many electronic bulletin boards are often busy.    To set up A-Talk to redial continuously, select Redial 

Continuously in the Options Modem dialog box.
13 Repeat steps 8-10.
14 When you have connected to the bulletin board, you will get a prompt asking for your name and 

possibly your password.    Type these in.



Saving a Tektronix Picture

To save a Tektronix Picture:

1 Give a command to your host which will send the image, but don't press the carriage return.
2 Choose the Save Picture command from the Tektronix File menu.
3 Make your choices in the Tektronix File Save Picture dialog box.
4 Click on OK.
5 Press the carriage return to execute the command to your host.
6 When all of the image has been displayed, choose End Save from the Tektronix File menu.    The 

image will be saved under the file name you selected.



Saving a Tektronix Bitmap

To save a Tektronix Bitmap:

1 Give a command to your host which will send the image, and press the carriage return.
2 Once the image is completely displayed, choose the Save Bitmap command from the Tektronix File 

menu.
3 Make your choices in the Tektronix File Save Bitmap dialog box.
4 Click on OK.
5 The image will be saved under the file name you selected.



Setting Line and Character Delays

To set line and character delays:

1 Some hosts expect data transmission to approximate normal typing speed.    Data will be transmitted 
too fast for these hosts unless you modify one or both of these two options: Line Delay and Char 
Delay.    Select Text Transfer from the Options menu.

2 The Options Text Transfer dialog box will appear. Select the amount of Line Delay and Character 
Delay you want.

3 Choose OK.



Connecting to a Remote Computer

To connect to a remote computer:

1 Select Communications from the Options menu.
2 The Options Communications dialog box will appear. 
3 Choose the Baud rate, which depends on your modem.
4 If you have multiple serial ports, you can select which Port, COM1: to COM4: that you want to use.
5 Check with your host's documentation to see how to set the Parity and No. Bits.    Most BBS's require 

8 bits, no parity.    Many hosts will accept either 8 bits no parity or 7 bits even parity.    Both setups will 
work for transmitting text files; but if you are transmitting a binary file, you must use 8 bits no parity.

6 Select one or two stop bits, depending on what your host accepts.
7 Choose the X-on/X-off, the CTS/RTS or no Handshake.
8 Check with your host's documentation before selecting half duplex or full duplex. 
9 Choose OK.
10 Select Modem from the Options menu.
11 The Options Modem dialog box will appear.    Select your line type, Pulse or Touch.
12 Select your Modem Type.
13 Choose OK.
14 Select Dial from the Phone menu.
15 Type the telephone number of the host in the Phone Dial dialog box. 
16      Choose OK.
17 If the line is busy, you will get a timeout or error message. Many hosts are often busy.    To set up A-

Talk to redial continuously, select Redial Continuously from the Options Modem dialog box.
18 Repeat steps 14-16.
19 When you have connected to the bulletin board, you will get a prompt asking for your name and 

possibly your password.    Type these in.



Disconnecting from a Remote Computer

To disconnect from a remote computer:

1 Log off from your host computer.
2 If you have a Custom modem, choose Modem from the Options menu. Otherwise, skip to number 5.
3 The Options Modem dialog box will appear.    Select Custom.
4 Choose the Hang Up command code or the Drop DTR option.
5 Choose OK for both dialog boxes.
5 Choose Hang Up from the Phone menu.



Receiving Binary Files with Protocols

To receive binary files:

1 Choose Communications from the Options Menu.
2 Select 8 for the No. Bits and None for Parity in the Options Communications dialog box.
3 Choose XON/XOFF, RTS/CTS or no Handshake.
4 Choose OK.
5 Connect to your remote computer.
6 Login to your host.
7 Choose Protocol Transfer from the Options menu.
8 The Options Protocol Transfer dialog box will appear.
9 For 1K-XMODEM, YMODEM Batch, YMODEM-g and ZMODEM, you may select CRC instead of the 

default checksum.
10 Choose the Protocol you would like to use.
11 Choose Binary under Type.
12 Choose OK.
13 Ask your host to send a file using a particular protocol.
14 Select Receive Protocol under the Transfer Menu.
15 For XMODEM and 1K-XMODEM, a Transfer Receive Protocol dialog box  will appear.    Select the 

drive and directory and type in the name under which you want the received file to be stored.
16 After the transfer has been completed, logoff from your host and hang up.



Receiving Text Files with Protocols

To receive text files:

1 Choose Communications from the Options Menu.
2 Check with your host's documentation before selecting the No. Bits and Parity from the Options 

Communications dialog box:    usually 8 bits, no parity or 7 bits, even parity.
3 Choose XON/XOFF, RTS/CTS or no Handshake.
4 Choose OK.
5 Connect to your remote computer.
6 Login to your host.
7 Choose Protocol Transfer from the Options menu.
8 The Options Protocol Transfer dialog box will appear.
9 For 1K-XMODEM, YMODEM Batch, YMODEM-g and ZMODEM, you may select CRC instead of the 

default checksum.
10 Choose the Protocol you would like to use.
11 Choose Text under Type.
12 Choose OK.
13 Ask your host to send a file using a particular protocol.
14 Select Receive Protocol under the Transfer Menu.
15 For XMODEM and 1K-XMODEM, a Transfer Receive Protocol dialog box will appear.    Select the 

drive and directory and type in the name under which you want the received file to be stored.
16 After the transfer has been completed, logoff from your host and hang up.



Sending Binary Files with Protocols

To send binary files:

1 Choose Communications from the Options Menu.
2 Select 8 for the No. Bits and None for Parity in the Options Communications dialog box.
3 Choose XON/XOFF, RTS/CTS or no Handshake.
4 Choose OK.
5 Connect to your remote computer.
6 Login to your host.
7 Choose Protocol Transfer from the Options menu.
8 The Options Protocol Transfer dialog box will appear.
9 For 1K-XMODEM, YMODEM Batch, YMODEM-g and ZMODEM, you may select CRC instead of the 

default checksum.
10 Choose the Protocol you would like to use.
11 Choose Binary under Type.
12 Choose OK.
13 Ask your host to receive a file using a particular protocol.
14 Select Send Protocol under the Transfer Menu.
15 The Transfer Send Protocol dialog box will appear.    Choose the drive and directory in which the file 

you want to send is stored.
16 Choose the file you want to send from the list box, or type in the file you want to send in the text box.
17 Choose OK.
18 After the transfer has been completed, logoff from your host and hang up.



Sending Text Files with Protocols

To send text files:

1 Choose Communications from the Options Menu.
2 Check with your host's documentation before selecting the No. Bits and Parity from the Options 

Communications dialog box:    usually 8 bits no parity or 7 bits even parity.
3 Choose XON/XOFF, RTS/CTS or no Handshake.
4 Choose OK.
5 Connect to your remote computer.
6 Login to your host.
7 Choose Protocol Transfer from the Options menu.
8 The Options Protocol Transfer dialog box will appear.
9 For 1K-XMODEM, YMODEM Batch, YMODEM-g and ZMODEM, you may select CRC instead of the 

default checksum.
10 Choose the Protocol you would like to use.
11 Choose Text under Type.
12 Choose OK.
13 Ask your host to receive a file using a particular Protocol.
14 Select Send Protocol under the Transfer Menu.
15 The Transfer Send Protocol dialog box will appear. Choose the drive and directory in which the file 

you want to send is stored.
16 Choose the file you want to send from the list box, or type in the file you want to send in the text box.
17 Choose OK.
18 After the transfer has been completed, logoff from your host and hang up.



Saving Control Codes in Incoming Text Files

To save control codes in incoming text files:

1 Select Text Transfer from the Options menu.
2 The Options Text Transfer dialog box will appear.
3 Select Plain under Receive.
4 Choose OK.



Printing Incoming Text

To print incoming text:

1        Select Print from the File menu.
2        The File Print dialog box.
3        Select the Capture to Printer check box.
4        Unselect the same check box,when you no longer want a printout.

See Also
      Getting a Cheap Printout



Selecting Flow Control for Text File Transfers

To select flow control:

1 Choose Communications from the Options Menu.
2 Choose XON/OFF, RTS/CTS or no Handshake from the Options Communications dialog box.
3 Choose OK.
4 Connect to your remote computer.



Saving in Tektronix PLOT-10 Format

To save in Tektronix PLOT-10 format:

1 Give a command to your host which will send the image, but don't press the carriage return.
2 Choose the Save Plot command from the Tektronix File menu.
3 Make your choices in the Tektronix File Save Plot dialog box.
4 Click on OK.
5 Press the carriage return to execute the command from your host.
6 When all of the image has been displayed, choose End Plot.



Replaying a Tektronix Plot

To replay a Tektronix plot:

1 Use the Save Plot command from the Tektronix File menu to capture a plot in standard Plot-10 
format.

2 Select the Replay command from the Tektronix File menu.
3 Give the file name of the previously saved image in the Tektronix File Replay dialog box.

See Also
Saving in Tektronix PLOT-10 Format



Setting Terminal Emulation

To set terminal emulation:

1 Select Terminal from the Options menu.
2 The Options Terminal dialog box will appear.
3 Choose the Emulator and Bell you want.
4 Choose OK.
5 Select VT SET-UP Display from the Options menu.
6 The Format VT SET-UP Display dialog box will appear.
7 Make your display selections under Auto/LF/CR, Auto Wrap, Columns, Cursor, Cursor Type, Line 

State, Margin Bell, Screen and Scroll.
8 Choose OK.
9 Select VT SET-UP Keyboard from the Options menu.
10 The Format VT SET-UP Keyboard dialog box will appear.
11 Make your keyboard selections under Answerback Message, Auto Answer, Backspace Mode, Cursor 

Keys, and Keypad.
12 Choose OK.
13 Select Fonts from the Options menu.
14 The Format Font dialog box will appear.
15 Make your font selections under Font, Font Style and Size.
16 Choose OK.



Timing Terminal Sessions

To time terminal sessions:

1 Select the Timer command from the View menu.    A checkmark will appear and timer/time will appear 
in the status bar.

2 Select the Timer command again from the View menu when you want to stop timing your terminal 
session. The checkmark will disappear.



Viewing Received Text Files

To view a received text file:

1 Make sure you have selected Receive Text Pause from the Transfer Receive Text menu.
2 Select View from the Transfer Receive Text menu.
3 Scroll through the file using Notepad.

See Also
Receiving Mail as Text



Specifying Modem Commands

To specify modem commands:

1 Select Phone Book from the Phone menu.
2 The Phone Book dialog box will appear.
3 Select the Modem button under the Phone Book Options buttons.
4 The Custom Modem dialog box will appear.
5 Check your modem manual to set up the modem command codes, the modem response codes, 

pacing and Drop DTR on Hang Up.
6 Choose OK.
7 You are now back in the Phone Book dialog box.    Choose OK.



Setting Up Tektronix Emulation

To set up Tektronix emulation:

1 Select Terminal under the Options menu.
2 The Options Terminal dialog box  will appear.
3 Select Tektronix 4014 under Terminal Emulation.
4 Choose OK. The Tektronix window will appear.
5 Select Controls nder the Tektronix Options menu.
6 The Tektronix Options Controls dialog box will appear.
7 Make your selections.
8 Click on OK.



Exiting A-Talk

To exit A-Talk, do the following:

1 Select Exit from the File menu.



Signing In to MAPI or Microsoft Mail

To sign in to Mail:

1 From your A-Talk window, select the message that you want to forward.
2 Select Send from the Edit menu.    The Mail Sign In dialog box will appear.
3 Type your mailbox name in the Name box, and then press TAB.
4 Type your password in the Password box, and then press ENTER or click on OK.
5 In any one Mail session, the sign in dialog box will appear only once unless you have cancelled the 

session.

See Also
Sending a Message with MAPI or Microsoft Mail



Sending a Message with MAPI or Microsoft Mail

To send a message with MAPI or Microsoft Mail:

1 Sign in to Mail. The Send Note dialog box will appear.
2 Address a message by choosing the Address button.
3 Mail displays the Address dialog box. Select a user and press ENTER or choose the To button.    

Press ENTER or choose the OK button.
4 In the Subject text box, type a short description of the message.
5 The message you have previously selected from the A-Talk window will appear in the text editor. Click

anywhere in the message body to start editing the message.
6 To attach a downloaded file, choose the Attach button and select the file from the Attach dialog box. 

Click on OK.
7 If desired, choose the Options button and make your selections.
8 Choose the Send button. The message disappears. This means your message has been sent.

See Also
Signing In to MAPI or Microsoft Mail



Adding a Network DDE Share

To add a Network DDE share:

1 With the mouse, select the area of the A-Talk window that you want to share.
2 Select Add Share from the Edit menu.    The Add Share dialog box will appear.
3 Type a name into the Share Name text box.    It is usual to end the name with a $ sign.
4 The share name will refer to the Application (always ATalk), the Topic (always Screen), and the Item, 

which is the cell range you selected from the screen before invoking the dialog box.    The Item is in 
R1C1 format and should not be changed unless you made a mistake when selecting the area of the 
screen.

5 Define password number 1 by selecting 1 under password.    Type the password into the text box.
6 Click on the permissions you would like associated with this password.    These are the five possible 

permissions:

Permission Access Type Means that
Request Read Client asks for information from the A-Talk screen
Poke Write Client updates A-Talk screen
Advise Read Client establishes hot link with the A-Talk screen 
Execute Execute Client invokes A-Talk command
Start App. Execute Client starts A-Talk if not already running

7 To define password number 2, select 2 under password.    Type the password into the text box.
8 Click on the permissions you would like associated with the second password.
9 Click on OK.

See Also
Deleting a Network DDE Share
Linking to a Network DDE Share
Unlinking from a Network DDE Share
Inserting DDE Hot and Warm Links



Linking to a Network DDE Share

To Link to a Network DDE share:

1 Make sure that a server has created one or more Network DDE shares. Then you can link to the 
share(s).

2 With the mouse, select the area of the A-Talk window that you want to link.
3 Select Link to Share from the Edit menu. The Link to Share dialog box will appear.
4 The Local Item Name string box should contain the initial row and column (in R1C1 format) of the 

selection you made before invoking the Link to Share dialog box. If no selection has been made, you 
will have to enter the row and column manually.

5 Choose the computer that defined the share to which you want to link by typing the name in the 
Computer Name string box or by selecting the Computer button which will display the Select a 
Computer dialog box. Make your selection.

6 Enter the share name to which you want to link in the Share Name string box.
7 Enter the item that you want to link in the Item name string box.    If you are linking to a share created 

by an A-Talk server, enter it in R1C1 format. 

See Also
Adding a Network DDE Share
Deleting a Network DDE Share
Unlinking from a Network DDE Share
Inserting DDE Hot and Warm Links



Unlinking from a Network DDE Share

To Unlink from a Network DDE Share:

1 Select Unlink from Share from the Edit menu. The Unlink from Share dialog box will appear.
2 In the Show Linked Items On list box, you will see, in outline form, the computers, the shares and the 

items you may unlink from. To unlink an item, you may do one of two things:
3 Click on the item you want to unlink from.    The item will appear in the Item Name text box.
4 Alternatively, you can click on the Share, and select the item from the drop-down list box.
5 Click on OK.

See Also
Adding a Network DDE Share
Deleting a Network DDE Share
Linking to a Network DDE Share
Inserting DDE Hot and Warm Links



Deleting a Network DDE Share

To Delete a Network DDE Share:

1 Select Remove Share from the Edit menu. The Remove Share dialog box will appear.
2 In the list box, you will see the shares you may remove. To delete a share, you may do one of the 

following:
3 Select the share to delete from the drop-down list box, by clicking on it. Click on OK.
4 Or double-click on the share.

See Also
Adding a Network DDE Share
Linking to a Network DDE Share
Inserting DDE Hot and Warm Links
Unlinking from a Network DDE Share



Inserting DDE Hot and Warm Links

To insert DDE hot and warm links to A-Talk ranges:

1 Select, with the mouse, the range in A-Talk.
2 Choose Edit Copy from the A-Talk menu.
3 Switch to the other application.
4 Position the cursor where you want the copied information to be displayed.
5 Select Paste Link or Paste Special, depending on your application.
6 Select either a warm or hot link from your application.    Different names may be used.    For example, 

a hot link might be called Auto Update or Automatic; a warm link might be called either No Auto 
Update or Manual.

See Also
Adding a Network DDE Share
Deleting a Network DDE Share
Linking to a Network DDE Share
Unlinking from a Network DDE Share



Copying a Tektronix Bitmap to the Clipboard

To copy a Tektronix Bitmap to the clipboard:

1 Display or Replay an image on the Tektronix window.
2 After the image is completely displayed, choose the Copy command from the Tektronix Edit menu.

See Also
Saving in Tektronix PLOT-10 Format
Replaying a Tektronix Plot
Copying a Tektronix Metafile to the Clipboard



Copying a Tektronix Metafile to the Clipboard

To copy a Tektronix Metafile to the Clipboard:

1 Give a command to your host which will send the image, but do not press the carriage return.
2 Choose the Copy Picture command from the Tektronix Edit menu.
3 Press the carriage return to execute the host's command.
4 When all of the image has been displayed, choose End Copy from the Tektronix Edit menu.

See Also
Saving in Tektronix PLOT-10 Format
Replaying a Tektronix Plot
Copying a Tektronix Bitmap to the Clipboard



Saving a Phone Book

To save a phone book:

1 Select Phone Book from the Phone menu.
2 Make changes or add to the phone book.
3 Click on the Save button. The Phone Book Save dialog box will come up.
4 To save with the current phone book name, directory and drive, click on OK.
5 Or make changes in the Phone Book Save dialog box and then click on OK.

See Also
Adding a Host to the Phone Book
Deleting a Host from the Phone Book



Deleting a Host from the Phone Book

To delete a host from the phone book:

1 Select Phone Book from the Phone menu.
2 Click on a host name in the list box.
3 Click on the Delete button.
4 If you want to delete the host permanently, select Save.
5 Click on OK.

See Also
Adding a Host to the Phone Book
Saving a    Phone Book



Dragging and Dropping Files

You can send files, set A-Talk communications parameters and execute scripts by dragging files from File 
Manager and dropping them into A-Talk.

To drag and drop a file into A-Talk:

1 Start File Manager by double-clicking on the icon in the Main group.
2 Start A-Talk by double-clicking on the icon.
3 Make sure that both the File Manager and A-Talk windows are visible on your screen.
4 Using File Manager, open the directory of the file you want to drag. Click with the left mouse button on

the file you want.
5 Hold down the left mouse button and drag the file onto the A-Talk window. Release the mouse button.

To: Drag and Drop:
Change settings A settings file with the extension .ATI
Send a text file A text file with the extension .TXT
Execute a scriptA script file with the extension .ATK
Send a file A file with any other extension.



The Script Language

A script is a program that simulates the same commands that you would be typing as responses to 
prompts from your host when you login or transfer files manually.    You will have to write a program that 
will wait for those prompts and then send the proper reply, such as a carriage return, your user ID or your 
password.

Some sample hosts with login scripts have already been set up for you and are included on the disk.    
You will have to edit all of the sample scripts in order to plug in your own ID and password. All of the 
sample login scripts are stored in a drawer called "Scripts". You may edit them with your favorite text 
editor.



Writing Your Own Script

To write your own script, do the following:

1 Select Script Editor from the Phone menu. The Script Editor window wil appear.
2 Place the cursor where you want the command to be added
3 Select Add from the Edit menu.
4 Select the desired command from the Command list box. Below the command box, look at the syntax of
the particular command you want to add.
5 If the command has parameters, select (one at a time) the parameters from the Parameter drop-down 
list box. 
6 After selecting a parameter, enter a value in the Value list box.
7 Click on Add.
8 Repeat steps 3 to 6 for as many commands as you want to add.
9 Select to Close to take you back to the Script Editor window.
10 Select Save from the File menu and enter a file name.
 
To edit a script, do the the following:

1 Select Script Editor from the Phone menu. The Script Editor window wil appear.
2 Select Open from the File menu and enter an existing file name.
3 Place the cursor on the command you want to change.
4 Select Change from the Edit menu.
5 Select the desired command from the Command list box. Below the command box, look at the syntax of
the particular command you want to change.
6 If the command has parameters, select (one a time) the parameters from the Parameter drop-down list 
box. 
7 After selecting a parameter, enter a value in the Value list box.
8 Click on Change. The command at the cursor will be replaced with the new command.
9 Select Save from the File menu and click on OK.

Notes:

All commands (except two-word commands such as IF TIMEOUT, IF ERROR and ECHO BUFFER) can 
be abbreviated to three letters and can be in capital or lower case letters.    

Set off strings with quotes. A string is a group of one or more characters enclosed in quotes. When writing
the strings that follow your commands, you will have to pay attention to whether your host uses small or 
capital letters.    Also pay attention to spaces which may be required when waiting for prompts from your 
host or when replying to your host. Beginning and ending double quotes are required when waiting for a 
string of characters.    

Use the caret (^) to indicate control characters, as in ^C for a control C.    Two carets (^^) indicate a caret 
character (^).    When waiting for the double quote symbol ("), indicate it by a ^".    The square brackets 
([...]) enclose optional parameters.    The brackets themselves must not be typed in. 

Insert comments or notes to yourself,    which will not be executed by the computer. Comments may be 
put into your script file preceded by the # sign.    For example:

WAIT "SEND TO:"
REPLY "BOB HACKER^M"
# Enter the subject of your letter.
WAIT "->"

Once you have written your script, you can start it in one of two ways: 



1) from the Script command in the Phone Menu; or 

2) from the Phone Book.



Script Commands

The A-Talk script language commands are, in alphabetical order:

ADVISE
ASK
AT
BAUD
BELL
BREAK
CD
CHAIN
CLEAR
CRC
DELAY
DIAL
ECHO
ECHO BUFFER
EDITLINE
EMULATOR
EXIT
FINISH
FONT
GETLINE
GOTO
HALT
HANGUP
HELP
IF
IF ERROR
IF TIMEOUT
INITIATE
INPUT
KGET
LOAD
MODE
MSGBOX
ON
PAUSE
POKE
PRINTER
PROTOCOL
PUTLINE
RECEIVE
REDIAL
REPLY
REQUEST
REWIND
SAY
SEND
SET
SPEECH
START
STOP
STRINGBOX
TERMINATE



TIMEOUT
TXRECEIVE
TXSEND
UNADVISE
WAIT
WRAP
XON



TXSEND

TXSEND will start a Send Text transfer from your PC to the host.

Format: TXSEND [ filename ]

Notice that the file name is not quoted!

Example:

WAIT "!"
REPLY "GO MAIL^M"
WAIT "CHOICE !"
REPLY "2^M"
WAIT "1: "
TXSEND cis.txt
WAIT "!"
REPLY "1^M"
WAIT "user ID): "
REPLY "12345,6789^M"
WAIT "Subject: "
# Enter the subject of your letter.
REPLY "Can we talk?^M"
WAIT "(Y or N)! "
REPLY "Y^M"
 
The example given is part of a script file for sending mail to CompuServe.      These commands will send 
your mail from an text file called cis.txt in the current disk drive to the host.    The "WAIT" command tells 
your PC to wait for the prompts from the host.    If you have ended your letter with the proper CompuServe
conventions (with a /EXIT^M), CompuServe will display a Send Menu prompt.

If the file name is omitted, the content of the communication buffer is used as the file name.



ASK

The ASK command allows you to set up a question or a series of questions.    The ASK command is used 
in conjunction with the IF command.    This feature will allow you to set up script files with menus which 
will appear asking you to type your selection from the keyboard.    The keyboard character you type will 
not be sent to the host.    It will serve to execute your command.

Format:  ASK "string" 

Example:

ASK "K)ermit, X)MODEM, or Y)MODEM?"
IF "K" PROTOCOL K
IF "X" PROTOCOL X
IF "Y" PROTOCOL Y

With this example, you set up a little menu that will appear while your script is executing.    It will ask you 
which protocol you want to use for a transfer:    Kermit, XMODEM or YMODEM Batch.

The character returned by the ASK command is stored in the communication buffer.



AT

The AT command will stop the execution of your script until a given time.    It is very useful if you want to 
go to bed and have your computer make transfers at night when telephone rates are cheaper.    Use the 
twenty-four hour format when putting in the time (for example, 8:00 PM would be 20:00).

Format: AT hour:min

Example:

AT 23:30
ON "NO CARRIER" GOTO login
login:
HANGUP
REPLY "ATDP213-555-1212^M"
TIMEOUT 30
WAIT "system?"
IF TIMEOUT GOTO login

This example of the AT command will stop the execution of your script until 11:30 PM.    The script will 
start executing at eleven thirty PM and will dial and redial if a connection is not made within thirty seconds
(the REPLY command is used with ON to dialjust add "ATDP" at the beginning for pulse dialing and "^M" 
at the end of your phone number).

This command cannot be executed by another application acting as the DDE client.



BAUD

To set the baud rate from your script, use this command.

Format: BAUD baud rate

Example:

BAUD 2400
SET F8N1
WRAP OFF
EMULATOR Ansi
FONT WinANSI

This example sets all parameters for connection to an IBM PC-based color Bulletin Board System. 



BELL

You can have the bell go off at any point in your script by using this command.

Format: BELL 

Example:

DELAY 1
REPLY "^M"
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)"
REPLY "^M"
WAIT "%"
REPLY "source setpc^M"
WAIT "%"
REPLY "mail^M"
BEL

This is an example of a login script for UNIX that you would use at home if you had a VT100 terminal at 
work.    The bell will ring when the host begins transmitting your mail. Notice that in the example only the 
first three letters of the BELL command have been used.    All commands (except two-word commands ) 
may be abbreviated to three letters.



BREAK

This command will send a break to your host, cutting off your connection.    Any character that is about to 
be sent will be aborted by this command.

Format: BREAK [value]

Example:

BREAK 750000

The optional value for the break is given in microseconds.    In this case the break is 750,000 
microseconds or .75 seconds.    If no value is given, the default break is .5 seconds (or 500,000 
microseconds).



CD

Use CD to change the local directory for file transfers.

Format: CD newdir

Example:

WAIT "!"
REPLY "GO MAIL^M"
WAIT "CHOICE !"
REPLY "2^M"
WAIT "1: "
CD C:\MAIL
TXSEND cis.txt
WAIT "!"
REPLY "1^M"
WAIT "user ID): "
REPLY "12345,5678^M"
WAIT "Subject: "
# Enter the subject of your letter.
REPLY "Can we talk?^M"
WAIT "(Y or N)! "
REPLY "Y^M"

This is the same example given under TXSEND for sending mail to CompuServe, but this time your script
file will change the directory to MAIL on C:.    It will send from a file called C:\MAIL\CIS.TXT.



CHAIN

Use the CHAIN command to link other script files to your login script.    By linking one file at a time, you 
can link as many files as you want to your original login script.    For example, script A can be linked to 
script B, which is in turn linked to script C and so on. If the CHAIN command is executed, the computer 
will read and execute the linked script(s) without returning to the original script.

Format: CHAIN filename

Example:

ASK "Select C)ompuserve or B)IX"
IF "C" CHAIN c:compuser.atk
IF "B" CHAIN c:bix.atk

This example will link to and execute a script for logging onto CompuServe or BIX, depending on whether 
"C" or "B" is selected from the keyboard.

This command cannot be executed by another application acting as the DDE client.



CLEAR

This command will clear the terminal screen, putting the cursor at the upper left-hand corner.

Format: CLEAR

Example:

DELAY 1
REPLY "^M"
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)"
REPLY "^M"
WAIT "%"
CLEAR

This is a sample of a login script that you might use to access a UNIX system and emulate a VT100 
terminal. Once the login is complete, and you have received the prompt (%) you might want to clear the 
screen of the login procedure. Do this with the command CLEAR.



STOP

This will stop a Receive Text transfer and close the file.

Format: STOP

Example:

WAIT "!"
REPLY "GO MAIL^M"
WAIT "choice !"
REPLY "1"
TXRECEIVE c:capture.cis
REPLY "^M"
WAIT "continue !"
STOP

This example is from a script file for capturing mail from CompuServe. When CompuServe sends the 
MAIL prompt, your mail has finished scrolling. You can then stop the receiving process.



CRC

This command will set or reset the CRC option.

Format: CRC ON/OFF or YES/NO

Example:

CRC ON
PROTOCOL Z
WAIT ">"
REPLY "sz hostfile^M"
RECEIVE

This example shows a file download with ZMODEM and CRC-32, if supported by the host ZMODEM 
program (the UNIX program "sz" in this case).



DELAY

A DELAY will suspend the script file for a specified number of seconds. You may need a DELAY to slow 
down the execution of the script file in crucial points.

Format: DELAY number

Example:

DELAY 1
REPLY "^M"
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"

This example will suspend the execution of the script for one second.    A DELAY is needed to make sure 
the host is ready to receive the following REPLY, a carriage return.



DIAL

By using this command, you can dial the telephone number with your modem.    The DIAL command is 
used in conjunction with the IF command.    If you want to dial the telephone in conjunction with the ON 
command, you must use REPLY.    See the REPLY command for an explanation of this.

Format: DIAL "string"

Example:

AT 23:30
retry:
DIAL "7435000"
IF "NO CARRIER" GOTO retry
IF "CONNECT 1200" GOTO conn1200
IF "CONNECT 2400" GOTO conn2400
IF TIMEOUT GOTO retry
conn1200:
ECHO "got connected at 1200"
GOTO done
conn2400
ECHO "got connected at 2400"
done:

This example is for an automatic dial and redial in case the phone is busy or connection, either at 1200 or
2400 baud, is not made within the timeout period.    This script is set up to start at 11:30 PM.



ECHO

This command will make a string appear on the terminal window during the login script.

Format: ECHO "string"

Example:

WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)"
REPLY "^M"
WAIT "%"
ECHO "Login successful"

By using the ECHO command in this example, the phrase "Login successful" will appear on the terminal 
window when the login has been completed.



ECHO BUFFER

This command will display the contents of the communication buffer on the terminal window.    It can be 
useful to inform you of the reason for a returned error.

Format: ECHO BUFFER

Example:

#Comment: Getting Formats from Excel LOAD "excel"
INITIATE ch1 "Excel" "System"
REQUEST ch1 "formats" 6
TERMINATE ch1
IF "Text" GOTO tlabel
ECHO "THE 6TH FORMAT IS "
ECHO BUFFER
GOTO end
tlabel:
ECHO "THE 6TH FORMAT IS TEXT"
end:

This example will ECHO the name of the sixth format for Excel.



EDITLINE

This command will get, from the host, a line of up to the carriage return or a maximum of 128 characters 
and will echo the characters back to the caller. The line can be edited by using the backspace and delete 
characters. This command is used to provide a "remote" 1-line editor.    This is useful if you want to turn 
your computer into a BBS.

Format: EDITLINE

Example:

REPLY "Username: "
EDITLINE
IF "Myname" GOTO PASS
REPLY "BAD USER NAME^M"
HANGUP
PASS:
REPLY "Password:"
EDITLINE
IF "Mypassword" GOTO LOGGEDIN
REPLY "BAD PASSWORD^M"
HANGUP
LOGGEDIN:
REPLY "YOU'RE LOGGED IN^M"

This example will request a user name and password from the serial port and the script will continue only 
with the valid user name and password.

The characters returned by the EDITLINE command are stored in the communications buffer.



EMULATOR

This command will set the terminal emulator type.

Format: EMULATOR name

Example:

EMULATOR Ansi

To set the emulator type to other terminals, use simply the name of the terminalonly the first three letters 
are significant:    VT220, VT100, VT52, H19, ANSI, TEK, TTY and VIDTEX for CompuServe.



EXECUTE

The EXECUTE function sends commands to a DDE server application. The parameters are the channel 
number and the execute string. The channel number is the identifier used by the corresponding INITIATE.
The execute string contains one or more commands to be executed by the server.
An error is returned if the channel number is not valid, if any errors occur when the server executes the 
commands in the execute string or if the command cannot be completed in 10 seconds. EXECUTE does 
not return data to the client.

Format: EXECUTE chan "command"

Chan is the channel used for the connection.
Command is a quoted string representing commands you want to carry out in the program specified by 

the channel connection. The form of the command depends on the server command language.

Many applications accept multiple commands by placing them between square brackets.

Example:

# Comment: DDE Execute makes Excel load AMORTIZE.XLS sheet
LOAD "excel"
INITIATE ch1 "Excel" "Sheet1"
EXECUTE ch1 "[open(\"library\amortize.xls\")]"
TERMINATE ch1

The above script makes a copy of Excel load the sheet file AMORTIZE.XLS from the LIBRARY directory. 
Note the use of the string \" for quotation marks; this is often a useful technique when sending execute 
strings that contain quotation marks.

Different server applications support different commands. In general, the commands that can be sent to 
an application are the commands in that application's menus, macro or script language.



EXIT

This will close the script and end the execution of A-Talk.

Format: EXIT

Example:

WAIT "!"
REPLY "GO MAIL^M"
WAIT "choice !"
REPLY "1"
TXRECEIVE c:capture.cis
REPLY "^M"
WAIT "continue !"
STOP
HANGUP
EXIT

This example will exit A-Talk after stopping the text file transfer.

This command cannot be executed by another application acting as the DDE client.



FINISH

This command will shut down a host Kermit server.

Format: FINISH

Example:

KGET file.c
WAIT "$"
FINISH



FONT

This command will set the font type.

Format: FONT name [ ptsize ]

Name is the name of the font.
Ptsize is an integer denoting the point size of the font. If omitted, the point size of the current font will be 
used.

Example:

WRAP OFF
EMULATOR Ansi
FONT WinANSI



GETLINE

This command will get, from the host, the number of characters specified.    If the number is not specified, 
this command will get the entire line up to the carriage return or a maximum of 128 characters.

Format: GETLINE [ number ]

Example:

GETLINE
LOAD "excel"
INITIATE ch1 "Excel" "Sheet1"
IF ERROR GOTO FAIL
POKE ch1 "R1C1"
TERMINATE ch1
GOTO end
FAIL:
ECHO "ERROR STARTING DDE ON EXCEL WITH SHEET1"
end:

In this example, GETLINE is used to transfer data from the host to a server application (Excel) in a DDE 
conversation.

The characters returned by the GETLINE command are stored in the communication buffer.



GOTO

This command jumps to a label at a different part of the script file.    A label can be any word that is not 
part of the script language and it cannot contain a space.    A jump may be forward or backward.

Format: GOTO label

Example: 

ON "NO CARRIER" GOTO login
login:
HANGUP
REPLY    "ATDP000-0000^M"
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)"
REPLY "^M"
WAIT "%"

This example sets up "login" as a label by putting it on a separate line with a colon after it.    The GOTO 
command will search for that label, jump to it and begin executing at this point.    
The example given could be used if you're logging onto an erratic host that is in the habit of dropping the 
line and giving you the message "NO CARRIER".    If this happens, you would want to start all over, redial 
and try to login again.    The GOTO feature would allow you to do that automatically.

This command cannot be executed by another application acting as the DDE client.



HANGUP

This command will drop the modem connection.

Format: HANGUP

Example: 

REPLY "^M"
WAIT "$"
REPLY "logout^M"
DELAY 1
HANGUP

This example is taken from a script exiting a VAX system running UNIX.



HELP

This command will display the A-Talk help index.

Format: HELP

Example:

HELP



IF

This command will look for and check characters in the communications buffer, either those typed in from 
the keyboard, those sent from the host, those returned from the modem, or those transferred through 
DDE. It is used in conjunction with the ASK, GETLINE, PUTLINE, WAIT, DIAL and the DDE commands 
REQUEST and POKE.

Format: IF "string" command

Example: 

ASK "Protocol (K,X,Y,Z)?"
IF "K" PROTOCOL K
IF "X" PROTOCOL X
IF "Y" PROTOCOL Y
IF "Z" PROTOCOL Z
GETLINE 9
IF "C-Kermit" SEND file1

To select (from the keyboard) a "K," "X," "Y" or "Z" to designate a protocol.    If you select K, the protocol 
you will be using to transfer files will be Kermit.    If the nine characters from the host happen to be the 
prompt "C-Kermit," your PC will send a file, beginning a Kermit transfer of "file1."



IF ERROR

This command will execute the following parameter command only if the preceding command had an 
error.

Format: IF ERROR command

The "IF ERROR" cannot be abbreviated!

Example:

GETLINE
LOAD "excel"
INITIATE ch1 "Excel" "Sheet1"
IF ERROR GOTO FAIL
POKE ch1 "R1C1"
TERMINATE ch1
GOTO end
FAIL:
ECHO "ERROR STARTING DDE ON EXCEL WITH SHEET1"
end:

In this example, if there is an error because the item "Sheet1" is not valid, the GOTO FAIL command will 
be executed and the error message will be echoed. If there is no error, the POKE command will be the 
next one executed.



IF TIMEOUT

This is a variation of the IF command.    Use the TIMEOUT command to set up the situation.

Format: IF TIMEOUT command

The "IF TIMEOUT" cannot be abbreviated!

Example:

TIMEOUT 20
login:
HANGUP
DIAL "000-0000"
WAIT "login:"
IF TIMEOUT GOTO login
REPLY "yourname^M"
WAIT "password:"
IF TIMEOUT GOTO login
REPLY "yourpassword^M"
WAIT "(vt100)"
IF TIMEOUT GOTO login
REPLY "^M"
WAIT "%"
IF TIMEOUT GOTO login

This example sets up "login:" as a label by putting it on a separate line with a colon after it.    The IF 
TIMEOUT GOTO command will be executed if each of the prompts ("login:", "password:", "(vt100)", %) is 
not sent by the host after twenty seconds.    This login script will start over with the label "login:".



INITIATE

The INITIATE function opens a DDE channel from an A-Talk client to a server application. The INITIATE 
function has two parameters, the server application name (also called Service) and the topic. The 
application name is the server program name without the .EXE extension. If the server application is not 
running, the INITIATE function automatically starts it. (INITIATE may not automatically start the server 
from some applications; this is a Microsoft convention.)

The topic identifies something in the server application that you plan to access. The topic is often the 
name of a window in the server application or the name of a file.

INITIATE also selects a channel number. The channel number is subsequently used as a parameter to all 
other DDE functions to identify the channel in use. You may have more than one channel open by calling 
the INITIATE function several times. A-Talk allows the use of 10 channels, named CH0 (channel 0) 
through CH9 (channel 9).

An error is returned if the server application is not running and cannot be started, or if the topic is not 
valid.

Format: INITIATE chan "app" "topic"

Chan is the channel used for the connection.
App is the DDE name of the application you are accessing.
Topic is the name of the topic in the application you are accessing.

Use "*" to indicate any application or any topic.
 
Example:

INITIATE ch0 "Excel" "system"
INITIATE ch1 "Excel" "Sheet1"
TERMINATE ch0
TERMINATE ch1 

The sample script above executes a copy of Excel and initiates two DDE channels to that copy of Excel. 
After this script is executed, no values will have been placed in new locations, but you will have 
successfully opened and closed two DDE channels.

If you substitute "*" in place of "Excel" in the example above you will establish communication with any 
one application that has "system" as the topic.

Please note the following:

1. Each time the INITIATE command is executed, a new DDE channel is opened. Each channel is 
assigned to a unique channel identifier, starting at CH0 and ending at CH9.

2. In the above example, DDE channels are initiated with the topics of "system" and "Sheet1". Any Excel 
sheet name is a valid topic for use in an INITIATE command. The topic of "system" allows you to ask 
Excel for specific system information. The topics are either "system" or the names of current 
documents.

The A-Talk INITIATE command may also be used to set up Network DDE conversations by using the 
following format:

Format: INITIATE chan "\\MACHINENAME\NDDE$" "SHARENAME$"



MACHINENAME is the name of the networked machine that runs the server.
NDDE$ is a fixed string that must be used to access the Network DDE features.
SHARENAME$ is the name of a share on the server.



INPUT

This command is useful if you want to set up your script files without, for example, the password.    You 
might want to do this if your script files are stored on diskettes that other people have access to.    You can
leave out the password or other important information from your login script and add an INPUT command 
that will ask you to type it in at the proper moment.    If you use this command, you must be present at the 
keyboard to type in the required information.    This command is not for unattended operation.

Format: INPUT "string"

Example:

WAIT "@"
INPUT "Type in TELENET access code now:"

With this example, the message "Type in TELENET access code now:" will appear on your screen, 
prompting you for the access code.



KGET

The KGET command will get files from the host Kermit.

Format: KGET filename

Example:

PROTOCOL K 
KGET *.c

This example of the command will transfer all of the files with the suffix "c" to your PC.



LOAD

The Load function starts a server application. 

Format: LOAD "app [params]" [num]

App is the path name of the server application to be loaded. If no path is listed, the server application 
must be in the current directory

Params is an optional parameter string to be passed to the application (for example, a file name).
Num is an optional window number (1 = normal size; 2 or omitted = minimized size; 3 = maximized size).

Example:

LOAD "c:\excel\excel c:\excel\annual.xls"
INITIATE ch9 "Excel" "annual.xls"

In the above example, the script first loads Excel and then initiates a conversation using the sheet 
"annual.xls" as the topic. Please note that if an application is not loaded, the INITIATE command will 
automatically load it.



MODE

With this command you choose the type of transfers to perform, binary or text.

Format: MODE binary or text

Example: 

MODE text
PROTOCOL Y
WAIT "$"
REPLY "upload *.c^M"
RECEIVE

This example refers to a YMODEM Batch text transfer.



MSGBOX

This command will display a message box.

Format: MSGBOX    "message"    ["title"]    [ type ]

Message is a string that will appear in the message box.
Title is the optional text in the title bar. If omitted, the text will be "A-Talk".
Type is an integer that defines the type and number of buttons in the message box, as follows:

Type Value Meaning
Button 0 (zero) OK button (default)

1 OK and Cancel buttons
2 Abort, Retry and Ignore buttons
3 Yes, No and Cancel buttons
4 Yes and No buttons
5 Retry and Cancel buttons

Symbol 0 (zero) No symbol (default)
16 Stop symbol
32 Question symbol
48 Attention symbol
64 Information symbol

Button action 0 (zero) First button is the default
256 Second button is the default
512 Third button is the default

After the user selects a button, the values returned in the communication buffer are:

Return Value Button pressed
1 Ok, Yes, or Abort
2 No or Retry
3 Cancel or Ignore
0 Not Enough Memory

Example:

MSGBOX "Exiting Script?" "BBS Script" 33
IF 1 GOTO bye
IF 2 GOTO continue
bye:
ECHO "Exiting script"
HALT
continue:

This example will put up a message box entitled "BBS Script".    The message box will ask a question, 
"Exiting Script?", and will display the OK and Cancel buttons.



ON

The ON command is a watchdog that looks for a string so that other commands can be invoked when 
such string is found. The behavior of the ON command depends on the command directly following it on 
the same line.

Format: ON "string" command

Example:

ON "NO CARRIER" GOTO login
login:
HANGUP
REPLY "ATDP000-0000^M"
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)"
REPLY "^M"
WAIT "%"

If a "NO CARRIER" is received from the host at any point in this script, the WAIT commands will be 
aborted and the GOTO command will be executed.    That means that the login script will be started over 
whenever the telephone line is dropped, as indicated by the message "NO CARRIER".

Related Topics
Multiple ON Strings



Multiple ON Strings

A maximum of three ON strings can be installed at any one time. They will be executed in a circular 
fashion, returning to the first when the last one has been executed.    The START and HALT commands 
clear all ON strings.

Example:

ON "NO CARRIER" GOTO login
ON "-more-" REPLY " "
ON ">" REPLY "^M"
login:
HANGUP
REPLY "ATDP000-0000^M"
WAIT "Name?"
SEND "Bob Hacker^M"
WAIT "Password?"
SEND "cracker^M"

In this example, the script will look for and execute a different command depending on what is received 
from the host. If the line disconnects, giving the message "NO CARRIER", the script will start over again, 
beginning from the label "login". Every time the string "-more-" is received, the script will reply with a 
space.    Every time the prompt ">" is received, the script will reply with a carriage return.

This command cannot be executed by another application acting as the DDE client.



TXRECEIVE

This command will start to receive a text file or will append to a previously PAUSEd transfer when the file 
name is omitted.

Format: TXRECEIVE [ filename ]

Example:

TXRECEIVE c:capture.c 
REPLY "cat mail^M"
WAIT "$"
STOP

This example will start receiving text, putting it in a file named capture.c on drive c:.    Then, the example 
will wait for the character '$' and STOP the transfer after receiving it.



POKE

The Poke function sends data to the server application. The parameters are the channel number and the 
item. The data is implicitly taken from the A-Talk communication buffer. The channel number is the same 
identifier used in the corresponding INITIATE. The item identifies the destination of the data in the server.

An error is returned if the channel number is not valid, the item is not valid, or the server is not able to 
accept the data.

Format: POKE chan "item"

Chan is the channel used for the connection.
Item is the name of the item in the application you are accessing.

Example:

# Comment: DDE Poke to Excel
GETLINE
LOAD "excel"
INITIATE ch1 "Excel" "Sheet1"
POKE ch1 "R1C1"
TERMINATE ch1

The sample script above executes a copy of Excel and places a value into a worksheet.    The following 
assumptions are made in this example:

1. A copy of Excel is being used as the second application for the DDE conversation.

2. The text to be sent over the DDE channel is contained in the A-Talk communication buffer and is 
obtained from the host using GETLINE.

3. The text will be placed into Sheet1 in the copy of Excel.



PRINTER

This command will turn the printer on or off, initiating a printer capture.    Remember that when you use 
this command, your session will be slowed to the speed of the printer.

Format: PRINTER ON/OFF or: PRINTER YES/NO

Example:

PRINTER ON
WAIT "end" 
PRINTER OFF



PROTOCOL

This command is used for selecting the protocol for file transfers.    It is used in conjunction with the 
SEND/RECEIVE commands.

Format: PROTOCOL single character (X, 1, Y, Z, K, W, G or B)

Example:

PROTOCOL X
SEND filename

In this example, the protocol XMODEM will be used to send a file called "filename".    An "X" stands for 
XMODEM, a "1" stands for 1K-XMODEM, "Y" stands for YMODEM Batch, "Z" for ZMODEM, "K" for 
Kermit, "W" for WXMODEM, "G" for YMODEM-g and "B" for CompuServe B+.



PUTLINE

This command will send to the host the contents of the A-Talk communication buffer.

Format: PUTLINE

Example:

# Comment: DDE request from Excel
LOAD "excel library\amortize.xls"
INITIATE ch2 "Excel" "amortize.xls"
REQUEST ch2 "R1C1"
TERMINATE ch2
PUTLINE

In this example, PUTLINE is used to transfer data from a server application (Excel) in a DDE 
conversation.



RECEIVE

Use this command to receive files from a host in any case except when using Kermit server mode, in 
which case the command to use is KGET.    The file name is required only with XMODEM and 1K-
XMODEM.

Format: RECEIVE [ filename ]

Example:

MODE text
PROTOCOL Y
WAIT "$"
REPLY "upload *.c^M"
RECEIVE

In this example you will be receiving from the host all the text files with the suffix "c".    You will be using 
the YMODEM Batch protocol for this batch transfer.



REDIAL

This command will select the redial type (o = once; t = ten times; c = continuously).

Format: REDIAL type (o/t/c)

Example:

REDIAL t
DIAL "213-1212"
REPLY "^M"
WAIT "login:"

The above example will dial the number up to ten times until connection is established.



REPLY

This command will send a string or a character to the host.

Format: REPLY "string"

Beginning and ending double quotes are required to send a string of characters. Use the caret (^) to send
control characters, as in "^C" to send a control C.    Two carets will transmit a single caret character.    The 
double quote symbol (") can be sent by ^".

Example:

WAIT "Name?" 
REPLY "Bob Hacker^M"

This example will reply with the name, Bob Hacker, followed by a carriage return (^M). Since the DIAL 
command does not work in conjunction with the ON command, it is sometimes necessary to use the 
REPLY command for dialing.    You can do this by adding an "ATDP" (for pulse dialing) or "ATDT" (for tone
dialing) at the beginning of the phone number and a "^M" at the end as follows:

REPLY "ATDP213-1212^M"



REQUEST

The REQUEST function gets data from the server application. The parameters are the channel number 
and the item. The channel number is the identifier used in the INITIATE. The item identifies the data to be 
returned.
The server application returns the desired data and A-Talk places it into its communication buffer. An error
is returned if the channel number is not valid, the item is not valid, or the server cannot return the data.

Format: REQUEST chan "item" [index]

Chan is the channel used for the connection.
Item is the name of the item in the application you are accessing.
Index is an optional numeric argument that selects the item from a list.

Example:

# Comment: DDE request from Excel
LOAD "excel library\amortize.xls"
INITIATE ch2 "Excel" "amortize.xls"
REQUEST ch2 "R1C1"
TERMINATE ch2
PUTLINE

The sample script above executes another copy of Excel and requests a value from a worksheet. The 
value is stored in the A-Talk communication buffer. The following assumptions are made in this example:

1. A copy of Excel is being used as the second application for the DDE conversation.

2. The value being requested is contained in cell A1 of AMORTIZE.XLS.

3. Your EXCEL directory is the current directory. After this macro is executed, the value in cell A1 of 
AMORTIZE.XLS can be found on the communication buffer, and can be sent to the host with the 
PUTLINE script command.

When you use the REQUEST command to request data from Excel, any referencing made must be in 
R1C1-type format. If this format is not used, the REQUEST command returns an error.



REWIND

The REWIND command is very similar to the GOTO command, except that the GOTO will search for a 
label.    The REWIND command will restart the script from the beginning of the script file. It is faster than 
jumping to a label at the beginning of a file because the computer will not have to search for the label.

Format: REWIND

Example:

ON "NO CARRIER" REWIND
REPLY "ATDP213-1212^M" 
WAIT "login:"
REPLY "yourname^M"
WAIT "password:"
REPLY "yourpassword^M"
WAIT "(vt100)" 
REPLY "^M"
WAIT "%"

Whenever the line to the host drops, giving you the message "NO CARRIER", this login script will go back
to the beginning, starting the login procedure all over again.

This command cannot be executed by another application acting as the DDE client.



SAY

This command, used in conjunction with the SPEECH command, will speak a string.    The SPEECH must
be ON for the SAY to work.

Format: SAY "string"

Example:

SPEECH ON
SAY "I am connected"
SPEECH OFF



SEND

This command will send files to the host with protocols.    Remember to specify a protocol before giving 
this command.

Format: SEND [ filename ]

Example:

PROTOCOL K
SEND file.wp

Notice that no quotes are used around the file name.

If the file name is omitted, the content of the communication buffer is used as the file name.



SET

This command will set the communications parameters by using the following format: the four digit format 
refers to full or half duplex (F or H), number of bits (7 or 8), parity (E for even, O for odd, N for no parity, M
for mark, and S for space), and number of stop bits (1 or 2).

Format: SET value

Example:

SET F8N1

This example will set the communications parameters to full duplex, 8 bits, no parity and one stop bit.



SPEECH

This command will start or stop the speech synthesizer.    If you want the computer to say something 
during the execution of the login script, you must use SPEECH in conjunction with the SAY command.

Format: SPEECH ON/OFF    or YES/NO

Example:

SPEECH ON
SAY "I am connected"
SPEECH OFF



START

This command will execute a new script file, returning to the first file once the new one has been 
executed.    Only one level of nesting is allowed.

Format: START filename

Example:

START c:cis.atk

In this example, you run your usual login script for CompuServe. The script is named CIS.ATK and is 
stored in the C: drive. With the START command you can use standard login scripts in larger, customized,
special purpose scripts.

This command cannot be executed by another application acting as the DDE client.



HALT

This will stop the execution of the script file.

Format: HALT

Example:

ON "NO CARRIER" HALT

This example will stop the script if the line drops and you get the "NO CARRIER" message.

This command cannot be executed by another application acting as the DDE client.



STRINGBOX

This command will display a dialog box where the user is able to enter a text or numeric string.

Format: STRINGBOX "prompt" [ "title" ] [ "default" ]

Prompt is the text displayed in the dialog box.
Title is the text in the title bar. If omitted, the text will be "A-Talk".
Default is the default text in the stringbox.

If OK is selected, the communication buffer will contain the string typed in at the keyboard. Otherwise, it 
will contain a null (empty) string.

Example:

STRINGBOX "Enter User Name" "Log on" "Bob Hacker"
IF "Bob Hacker" MSGBOX "Hi, Bob" "Log on" 0
IF "John Hacker" MSGBOX "Hi, John" "Log on" 0



PAUSE

The PAUSE command will suspend, or temporarily stop, receiving incoming data.

Format: PAUSE

Example:

TXRECEIVE a:capture.txt
WAIT "$"
REPLY "cat file1^M"
WAIT "$"
PAUSE
REPLY "cat file2^M"
WAIT "$"
TXRECEIVE
REPLY "cat file3^M"
WAIT "$"
STOP

This example will start receiving incoming data, storing it all under a file called "capture.txt" on drive A:.



TERMINATE

The TERMINATE function closes a DDE channel. The parameter is the channel number of the DDE 
channel to close. An error is returned if the channel number is not valid.

Format: TERMINATE chan

Chan is the channel used for the connection.

Example:

TERMINATE ch0



TIMEOUT

This will set the timeout for WAITs which come after it. Set the timeout value in number of seconds.    
Remember that if you do not put a number down, the default is forever! That means if you are waiting, for 
example, for a "password:" prompt which never arrives, and you have not set the timeout with a number 
of seconds, the script will lock up if the prompt is never received.    You can get out of this locked situation 
by selecting the End Script option in the Phone menu.

Format: TIMEOUT number

Example:

TIMEOUT 30
WAIT "User Name:"

In this example, the script file will wait (for the string "User Name:") for a maximum of thirty seconds 
before timing out.



WAIT

This command suspends the script file until a particular string is received. Beginning and ending double 
quotes are required when waiting for a string of characters. Use the caret (^) to indicate a WAIT for 
control characters, as in ^C when waiting for a control C.    Two carets (^^) indicate a WAIT for a caret 
character (^).    When waiting for the double quote symbol ("), indicate it by a ^". A WAIT command with no
string following it will be an endless wait.

Format: WAIT "string" or WAIT

Example:

ON "NO CARRIER" GOTO retry
ON "CONNECT 1200" GOTO conn1200
ON "CONNECT 2400" GOTO conn2400
retry:
REPLY "ATDP7435000^M"
WAIT
conn1200:
ECHO "got connected at 1200"
GOTO done
conn2400:
ECHO "got connected at 2400"
done:

The WAIT in the example will go on until one of three ON strings is received, "CONNECT 1200", 
"CONNECT 2400" or "NO CARRIER".    If "CONNECT 1200" is received, the script will jump to the label 
"conn1200:" and ECHO the string "got connected at 1200".    Then the script will jump to the label "done:". 
If "CONNECT 2400" is received, the script will jump to the label "done:" and ECHO the string "got 
connected at 2400".    If "NO CARRIER" is received, the script will dial again.    If none of the three strings 
is received, the script will be locked.    You can get out of this locked situation by selecting the End Script 
option in the Phone menu.



WRAP

This command will select the auto-wrap feature.

Format: WRAP ON/OFF or YES/NO

Example:

WRAP OFF
EMULATOR Ansi



XON

This command will set the XON/XOFF handshake.

Format: XON ON/OFF or YES/NO

Example:

XON ON
TXSEND local.txt
WAIT ".^M"
XON OFF

This example sends a text file to a "slow" host that supports XON/XOFF.



ADVISE

The ADVISE function sets up a hot link with a DDE server application.    The parameters are the channel 
number, the item and the location in R1C1 reference style. The channel number is the identifier used 
in the INITIATE. The item identifies the data to be hot linked. When the data in the server application 
changes, the server returns the desired data and A-Talk places it into the location referenced in the third 
parameter. An error is returned if the channel number is not valid, the item is not valid, or the server 
cannot hot link the data.

Format: ADVISE chan "item" "location"

Chan is the channel used for the connection.
Item is the quoted name of the item in the application you are accessing.
Location is a reference to the A-Talk screen location in R1C1 style.

Example:

# Comment: DDE advise from Excel
LOAD "excel library\amortize.xls"
INITIATE ch2 "Excel" "amortize.xls"
ADVISE ch2 "R1C1" "R2C10"

The sample script above executes another copy of Excel and hot links a value from a worksheet. If the 
value changes, the A-Talk screen at row 2, column 10 will be updated. The following assumptions are 
made in this example:

1. A copy of Excel is being used as the second application for the DDE conversation. The value being hot 
linked is contained in cell A1 of AMORTIZE.XLS.

2. Your EXCEL directory is the current directory.    If the value in cell A1 of AMORTIZE.XLS changes, its 
value can be found at location R2C10 on the A-Talk screen.

When you use the ADVISE command to hot link data from Excel, any referencing made must be in R1C1-
type format. If this format is not used, the ADVISE command returns an error.



UNADVISE

The UNADVISE function cancels a hot link with a DDE server application.    The parameters are the 
channel number and the item. The channel number is the identifier used in the INITIATE and ADVISE. 
The item identifies the data that has been hot linked. An error is returned if the channel number is not 
valid, the item is not valid, or an ADVISE has not been executed for the data.

Format: UNADVISE chan "item"

Chan is the channel used for the connection.
Item is the quoted name of the item in the application you are accessing.

Example:

# Comment: DDE unadvise from Excel
LOAD "excel library\amortize.xls"
INITIATE ch2 "Excel" "amortize.xls"
ADVISE ch2 "R1C1" "R2C10"
# other commands
UNADVISE ch2 "R1C1"

The sample script above executes another copy of Excel and hot links a value from a worksheet. If the 
value changes, the A-Talk screen at row 2, column 10 will be updated. It then executes other commands 
and then terminates the link with UNADVISE. The following assumptions are made in this example:

1. A copy of Excel is being used as the second application for the DDE conversation.

2. The value being hot linked is contained in cell A1 of AMORTIZE.XLS.

3.Your EXCEL directory is the current directory.




